Microsoft 365 features that help users manage their subscriptions, account settings, and billing information.
I've been working on this the past 3 days. Recently we add multi factor security for our users and after that an inhouse application which sent emails via SMTP authentication failed to authenticate the user. I removed the MFA from the user but it didn't help. Here's how I finally solved it with the help of this thread and this one. [SOLVED] Everything using Office 365 SMTP authentication is broken, wont authenticate? - Spiceworks
First find the reason its not authenticating. You can go into the Azure AD Admin Center-> Users->Sign Ins
FInd the user and incident where it failed. In my case the application was "Office365 Exchange Online" The reason for failure was "
Access has been blocked by Conditional Access policies. The access policy does not allow token issuance."
This is a default policy that apparently is created when Modern Authentication is turned on which is a prerequisite for MFA. To get my authentication back and keep the MFA, i had to uncheck the modern authentication, create a policy for MFA sign ins.
Uncheck modertn authentication: 365 admin center -> Settings -> org settings -> Modern authentication.
To create conditional policies: Azure AD Admin Center->Azure AD -> Security ->Conditional Access
- New Policy Select the users or groups , Grant -> Require MFA
Enable policy and Save.
This solved my specific problem.