Hi Gerry,
Sorry, I didn't understand what your first message was about until I reread it today.
Here is the latest error, but it was yesterday, and my computer did not blue screen at all yesterday, so I don't know if it is relevant:
The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
{C97FCC79-E628-407D-AE68-A06AD6D8B4D1}
and APPID
{344ED43D-D086-4961-86A6-1106F4ACAD9B}
to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.
The Network List Service service depends on the Network Location Awareness service which failed to start because of the following error:
The dependency service or group failed to start.