Error code CAA90049 - Any M365 App

Anonymous
2024-04-08T18:25:48+00:00

Hello, I have a remote end user that is receiving this error code when trying to sign into any M365 app. Once we close the error message the apps work perfectly fine but this happens daily when signing on and I would like to find a permanent fix. I would attach a screenshot but that doesn't seem to be working right now.

  • User enters login credentials and Microsoft authenticator code then this error pops up for any m365 app / teams / OneDrive.
  • User is in another state so can't come into office.

Something went wrong

We couldn't sign you in. If this error persists, contact your system administrators and provide the error code CAA90049.

Error code: CAA90049

Correlation ID: 9a55***1d07

Server message: Session key is empty

Any help is appreciated.

Thank you

[PII is removed by moderator]

Microsoft 365 and Office | Subscription, account, billing | For business | Other

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments

67 answers

Sort by: Newest
  1. Anonymous
    2024-08-05T20:24:25+00:00

    Same goes for my ticket. Still pending with O365 support. I will check the suggestions and see if it will work on our end.

    Was this answer helpful?

    0 comments No comments
  2. Anonymous
    2024-08-05T20:06:52+00:00

    Any time I submit a ticket to O365 support and they find out that we are using a Server OS, O365 support closes the ticket and tells me that 'contact Server support." So in my experience, O365 support won't assist if you are using a Server OS. And when I have contacted Server OS support, I've been told to contact O365 support. How can we actually get support for the products we pay for?

    Was this answer helpful?

    0 comments No comments
  3. Anonymous
    2024-08-05T14:18:41+00:00

    Got a response back recently from Omnissa (Vmware Horizon) support.

    They stated it is a Microsoft update that broke this function and they themselves are trying to get it resolved with Microsoft.

    They also suggested putting pressure on Microsoft by submitting a ticket with them to fix it in a future update.

    Like others have alluded to in these replies, a temporary fix could be undoing that update. However, I, personally, have not tested this yet to confirm.

    Was this answer helpful?

    0 comments No comments
  4. Anonymous
    2024-07-31T12:31:27+00:00

    We had the same problem after an upgrade to Server 2022 with FSLogix HF4 (2.9.8884.27471), after we set the "RoamIdentity" to "1" via GPO it works fine.

    https://learn.microsoft.com/en-Us/fslogix/reference-configuration-settings?tabs=profiles#roamidentity

    Was this answer helpful?

    0 comments No comments
  5. Anonymous
    2024-07-30T19:34:23+00:00

    I don't want to speak too soon, but I may have fixed our issue.

    I had been using Golden image without vTPM and having Horizon add the vTPM on the instant clones.

    I created a new pool, used the exact same golden image and snapshot but did not tell Horizon to add the vTPM. I am refreshing on logoff. 2 days now and not 1 user had to disconnect/reconnect the "access work or school" setting. I'm not ready to call it solved after just 2 days, but I'm actually hopeful at this point.

    Was this answer helpful?

    0 comments No comments