Stuck in import pst problem

Anonymous
2022-10-21T21:05:37+00:00

Hello All,

I'm stuck in a very strange problem and need help.

I imported pst file to m365 exchange using lifecycle data management console (https://compliance.microsoft.com), i sent as usal my pst using azcopy; i validate my mapping file and then i launched import to 365, as I maded it several times.

After a long time (my pst are quite little (12 gb in two files) i got an import error.

The same error appears on log with each pst.

Many thanks for helping me.

Best regards.

Herve

*******************************************

Here are the logs :

PST Filename,Target Mailbox,Import Status,Error,Total Items,Item Imported,Target Folder,Skipped Item Count,Last Failure,Total Item Size,Imported Item Size

mypstfilename.pst,___@___.___,Failed,Unknown,0,0,,0,System.NullReferenceException: Object reference not set to an instance of an object.

at Microsoft.IdentityModel.Clients.ActiveDirectory.AuthenticationContext.RunAsyncTaskT

at Microsoft.Office.Compliance.Ingestion.OAuthProvider.GetAppTokenFromESTS(OAuthTokenType tokenType, String tenantId, String serviceName, String serviceHostName) in k:\dbs\sh\nibr\1018_000434\cmd\0\sources\dev\ingestion\src\workloadapi\PSWSProvider\OAuthProvider.cs:line 492

at Microsoft.Office.Compliance.Ingestion.OAuthProvider.OAuthHackToInsertServicePrincipal(String tenantId) in k:\dbs\sh\nibr\1018_000434\cmd\0\sources\dev\ingestion\src\workloadapi\PSWSProvider\OAuthProvider.cs:line 238

at Microsoft.Office.Compliance.Ingestion.OAuthProvider.GetAppTokenFromAcs(OAuthTokenType tokenType, String tenantId, String serviceName, String serviceHostName) in k:\dbs\sh\nibr\1018_000434\cmd\0\sources\dev\ingestion\src\workloadapi\PSWSProvider\OAuthProvider.cs:line 463

at Microsoft.Office.Compliance.Ingestion.OAuthProvider.<>c__DisplayClass18_0.<GetTenantToken>b__0(String serviceName) in k:\dbs\sh\nibr\1018_000434\cmd\0\sources\dev\ingestion\src\workloadapi\PSWSProvider\OAuthProvider.cs:line 198

at Microsoft.Office.Compliance.Ingestion.OAuthProvider.GetAuthToken(OAuthTokenType tokenType, String tenantId, String serviceHostName, Func`2 authentication) in k:\dbs\sh\nibr\1018_000434\cmd\0\sources\dev\ingestion\src\workloadapi\PSWSProvider\OAuthProvider.cs:line 367

at Microsoft.Office.Compliance.Ingestion.OAuthProvider.GetUserToken(OAuthTokenType tokenType, String tenantId, String upn, String puid, String serviceHostName, Boolean usingSts) in k:\dbs\sh\nibr\1018_000434\cmd\0\sources\dev\ingestion\src\workloadapi\PSWSProvider\OAuthProvider.cs:line 215

at Microsoft.Office.Compliance.Ingestion.PswsOAuthAuthenticator.Authenticate(HttpWebRequest request) in k:\dbs\sh\nibr\1018_000434\cmd\0\sources\dev\ingestion\src\workloadapi\PSWSProvider\PswsOAuthAuthenticator.cs:line 106

at Microsoft.Exchange.PswsClient.PswsCmdlet.InternalRun()

at Microsoft.Exchange.PswsClient.NewPswsCmdlet`1.Run()

at Microsoft.Office.Compliance.Ingestion.ExchangeIngestionProvider.CreateNewMailboxImportRequest(String targetId, String azureBlobStorageAccountUri, String azureBlobSASToken, Boolean isArchive, String azureStatusPublishEndpointInfo, String name, String targetRootFolder, Nullable`1 contentCodePage, Int32 unrecognizedMailLimitPercent, String rulesBlobSasUri, ILogWriter logWriter, String& cmdText, String& error) in k:\dbs\sh\nibr\1018_000434\cmd\0\sources\dev\ingestion\src\workloadapi\IngestionProvider\ExchangeIngestionProvider.cs:line 727,0,0

Microsoft 365 and Office | Subscription, account, billing | For business | Other

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments
Answer accepted by question author
Anonymous
2022-11-17T07:29:59+00:00

I've not yet had to do another import, but on my support ticket they said it was now fixed.

Was this answer helpful?

2 people found this answer helpful.
0 comments No comments
Answer accepted by question author
Anonymous
2022-11-10T16:42:09+00:00

Are you still having this issue?

Everything looks good on my end with the 365 import service among other things.

I'm also unable to find incident EX450352 anywhere under service health or via Google.

Was this answer helpful?

1 person found this answer helpful.
0 comments No comments

50 additional answers

Sort by: Oldest
  1. Anonymous
    2022-10-22T16:33:52+00:00

    Dear Hervé Franco,

    Good day! Thank you for posting to Microsoft Community. 

    Based on your description, I understand that you have a concern with "import .pst". At this very moment, I am looking into whether there could be a possible solution to this issue. I will get back to you as soon as I get any additional information about your query. Thank you.

    Your patience and cooperation are much appreciated.

    Sincerely,

    Freddy | Microsoft Community Moderator

    Was this answer helpful?

    0 comments No comments
  2. Anonymous
    2022-10-23T07:21:40+00:00

    Hello Freddy

    We succeeded in migration.

    We used a third party software.

    The error may come from impersonate rights in exchange.

    I will make a test on Monday and I will post a feedback.

    Best regards

    Was this answer helpful?

    0 comments No comments
  3. Anonymous
    2022-10-24T09:20:05+00:00

    Hi there,

    it would be great if you could continue to look into this problem as we're also facing the exact same error message.

    We've verified with "test.pst" which only contains 1 email with 1 picture and nothing else

    • cannot import to AAD Sync user
    • cannot import to Cloud user
    • same "test.pst" works on another tenant (different customer, same region)
    • a "new.pst" from a different customer also fails to import to a synced and cloud only user
    • we saw the AdminDisplayVersion increasing over the weekend (starting with 15.20.5746.19) but still fails today
    • adding the "applicationimpersonation" role also didnt help
    • we tested with and without security defaults
    • the "Diag: Enable Basic Auth in EXO" says nothing is blocked and on the "normal page" every box is checked
    • its been over 48 hours after "Enable-OrganizationCustomization" and assigning the import role
    • the Tennant was freshly created on Friday
    • no account has MFA configured at the moment

    Was this answer helpful?

    1 person found this answer helpful.
    0 comments No comments