Sudden failure to send emails through specified SMTP server with python script

Anonymous
2021-07-15T20:57:04+00:00

Hi,

We have been sending automated emails through a python script for a while now and suddenly getting this error:

Failed to send an E-mail through the specified SMTP server [smtp.office365.com]:
Mailbox unavailable. The server response was: 5.2.252 Sender throttled due to continuous send as denied errors.
[Hostname=BN9PR12MB5179.namprd12.prod.outlook.com]

All of the login/password information is correct in the python script for sending the email, so why is this suddenly happening?

Microsoft 365 and Office | Subscription, account, billing | For business | Other

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments

43 answers

Sort by: Newest
  1. Anonymous
    2021-07-22T14:03:31+00:00

    Some good news here. For the first time in the past week, we don't have the error message when sending out email from applications. I am not sure if this is because MS fixed the issue or we haven't reach the threshold yet. I will keep monitoring this and report back here.

    Can someone please verify if this got fixed for you as well?

    Thanks

    Was this answer helpful?

    0 comments No comments
  2. Anonymous
    2021-07-22T13:44:05+00:00

    This is causing major issues and Microsoft won't get back to us. Can you please resolve this? I spent hours and hours looking at this for a few days before I saw this thread.

    Was this answer helpful?

    0 comments No comments
  3. Anonymous
    2021-07-22T10:07:01+00:00

    We have been having this issue all week.

    On our UK customer sites, our Service application that has been running flawlessly for months now times out when sending via SMTP. Restarting the service temporarily fixes the issue but it reoccurs a few times every day. This is only affecting Office 365 SMTP servers.

    For us, login fails with a 535 error.

    Was this answer helpful?

    0 comments No comments
  4. Anonymous
    2021-07-21T16:10:22+00:00

    Having the same issue; account is already business standard; problem started at 9:15 CDT this morning. Emails aren't being sent even if the from / reply to is the actual account, not a "send-as", although the bounce message remains the same.

    Ticket opened with MSFT as well.

    Was this answer helpful?

    0 comments No comments
  5. Anonymous
    2021-07-21T15:08:23+00:00

    Investigating potential workarounds led me to delete our SMTP service account and recreate it with the same name and password as our original configuration and it seems to be working now.

    Obviously this isn't an ideal fix and I'm not sure how long it will last but maybe it can help some of you guys hobble along until Microsoft fixes their issue!

    Was this answer helpful?

    0 comments No comments