I have this issue also, I use a scripted email to reply to tickets...
my error is
SMTP Error: data not accepted.SMTP server error: DATA END command failed Detail: 5.2.252 Sender throttled due to continuous send as denied errors. [Hostname=BYAPR15MB2199.namprd15.prod.outlook.com]
I use tls, SMTP, smtp.office365.com, port 587, authorize and send-as / from using the username and password on the account.
Everything was working flawlessly until recently it became unreliable. This account did send out my inventory feeds this morning
but I'm worried because at the moment its having the issue above.
Does the From name need to be blank? it sporadically works both ways by setting the From the accounts email. and either
setting the From Name to be blank or to the actual account display name.
just trying to resolve the 'continuous send as denied errors' !
Thank you.
I went through all my scripts and set the FromName to specifically match the accounts display name.
There were a few legacy (descriptive) FromName(s) on some. Not sure if this is the answer but my apps have sent a few responses out as needed. We will see if it continues to do so.... Maybe Microsoft no longer ignores the FromName?
Mine seems to have started working around the same time as Franks... coincidence?
Just glad to have it all working.
OK not working, still sporadic, I'm beginning to believe this is a volume on account issue. looks like the
'data not accepted.' lasts for ~6hrs
looking into other options.