Office 365 SMTP authentication failing, even with correct account information

Anonymous
2020-02-10T16:38:43+00:00

On my Wordpress site I've run into a problem in the last day or so, where emails simply fail to send. Before today it was running flawlessly for two months. The account information/password/username etc have not changed in that two months.

I'm using a Wordpress plugin called WP Mail SMTP to facilitate the sending of all outgoing emails. The error log I'm getting from the email test on that is as follows:

Versions:

WordPress: 5.3.2

WordPress MS: No

PHP: 7.3.14-5+0~20200202.52+debian9~1.gbpa71879

WP Mail SMTP: 1.8.1

Params:

Mailer: smtp

Constants: No

ErrorInfo: SMTP Error: Could not authenticate.

Host: smtp.office365.com

Port: 587

SMTPSecure: tls

SMTPAutoTLS: bool(true)

SMTPAuth: bool(true)

Server:

OpenSSL: OpenSSL 1.1.1d 10 Sep 2019

SMTP Debug:

2020-02-10 16:36:56 Connection: opening to smtp.office365.com:587, timeout=300, options=array ()

2020-02-10 16:36:56 Connection: opened

2020-02-10 16:36:56 SERVER -> CLIENT: 220 LNXP123CA0008.outlook.office365.com Microsoft ESMTP MAIL Service ready at Mon, 10 Feb 2020 16:36:55 +0000

2020-02-10 16:36:56 CLIENT -> SERVER: EHLO www.*****.com

2020-02-10 16:36:56 SERVER -> CLIENT: 250-LNXP123CA0008.outlook.office365.com Hello [***]250-SIZE 157286400250-PIPELINING250-DSN250-ENHANCEDSTATUSCODES250-STARTTLS250-8BITMIME250-BINARYMIME250-CHUNKING250 SMTPUTF8

2020-02-10 16:36:56 CLIENT -> SERVER: STARTTLS

2020-02-10 16:36:56 SERVER -> CLIENT: 220 2.0.0 SMTP server ready

2020-02-10 16:36:56 CLIENT -> SERVER: EHLO www.zestpromotional.com

2020-02-10 16:36:56 SERVER -> CLIENT: 250-LNXP123CA0008.outlook.office365.com Hello [***]250-SIZE 157286400250-PIPELINING250-DSN250-ENHANCEDSTATUSCODES250-AUTH LOGIN XOAUTH2250-8BITMIME250-BINARYMIME250-CHUNKING250 SMTPUTF8

2020-02-10 16:36:56 CLIENT -> SERVER: AUTH LOGIN

2020-02-10 16:36:56 SERVER -> CLIENT: 334 VXNlcm5hbWU6

2020-02-10 16:36:56 CLIENT -> SERVER: c2FsZXNAemVzdHByb21vdGlvbmFsLmNvbQ==

2020-02-10 16:36:56 SERVER -> CLIENT: 334 UGFzc3dvcmQ6

2020-02-10 16:36:56 CLIENT -> SERVER: QmFkMzM4MzA=

2020-02-10 16:37:02 SERVER -> CLIENT: 535 5.7.3 Authentication unsuccessful [LNXP123CA0008.GBRP123.PROD.OUTLOOK.COM]

2020-02-10 16:37:02 SMTP ERROR: Password command failed: 535 5.7.3 Authentication unsuccessful [LNXP123CA0008.GBRP123.PROD.OUTLOOK.COM]

SMTP Error: Could not authenticate.

2020-02-10 16:37:02 CLIENT -> SERVER: QUIT

2020-02-10 16:37:02 SERVER -> CLIENT: 221 2.0.0 Service closing transmission channel

2020-02-10 16:37:02 Connection: closed

SMTP Error: Could not authenticate.

Does anyone have any ideas at all? I'm completely at a loss here.

Microsoft 365 and Office | Subscription, account, billing | For home | Windows

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments

48 answers

Sort by: Most helpful
  1. Anonymous
    2020-06-26T09:09:44+00:00

    @all i think this ist the solution:

    I had the same Problems, old offic365 accounts work, new accounts did not work. After searching for 5 hours i get a solution:

    In the old accounts SmtpClientAuthenticationDisabled is false by default on online Exchange, in the new accounts it is True by default.

    I had to set it to false by exchange online powershell and also hat do go to e-mail-apps and set the hook to authenticated smtp

    after that it worked. Here you can read what is to do by exchange powershell:

    https://docs.microsoft.com/en-us/exchange/clients-and-mobile-in-exchange-online/authenticated-client-smtp-submission

    Steps in Powershell:

    $UserCredential = Get-Credential

    $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid/ -Credential $UserCredential -Authentication Basic -AllowRedirection

    Import-PSSession $Session -DisableNameChecking

    Take a look if it is True: Get-TransportConfig  (if there is True set to false)

    Set-TransportConfig -SmtpClientAuthenticationDisabled $false

    Take a look again if it works: Get-TransportConfig

    Remove-PSSession $Session

    In Admin Center --> acitve Users --> click the user --> email-apps --> click the hook --> authenticated smtp

    With this combination it worked for me. Hope this can help you all

    Was this answer helpful?

    50+ people found this answer helpful.
    0 comments No comments
  2. Anonymous
    2020-08-13T16:57:22+00:00

    Hey everyone,

    For anyone facing the failing authentication issue, I can suggest one thing to try that did solve the problem for me. Granted, there are many possible sources of the problem, so this suggestion won't necessarily fix the issue of course.

    In your Microsoft 365 Admin Center under the User tab, you have the ability to allow/disallow Email Apps. Head over to https://admin.microsoft.com/AdminPortal/Home#/users and click on the user that is facing the issues. In the "Email" tab of the modal that opened you'll be able to manage the Email Apps. Select Authenticated SMTP and click save.

    In our specific case that fixed the issue.

    I hope that helped :)

    Cheers

    Was this answer helpful?

    10 people found this answer helpful.
    0 comments No comments
  3. Anonymous
    2021-04-08T22:08:20+00:00

    Hey everyone,

    For anyone facing the failing authentication issue, I can suggest one thing to try that did solve the problem for me. Granted, there are many possible sources of the problem, so this suggestion won't necessarily fix the issue of course.

    In your Microsoft 365 Admin Center under the User tab, you have the ability to allow/disallow Email Apps. Head over to https://admin.microsoft.com/AdminPortal/Home#/users and click on the user that is facing the issues. In the "Email" tab of the modal that opened you'll be able to manage the Email Apps. Select Authenticated SMTP and click save.

    In our specific case that fixed the issue.
    I hope that helped :)

    Cheers

    This saved the day for me! Excellent. Can’t thank you enough.

    Was this answer helpful?

    9 people found this answer helpful.
    0 comments No comments
  4. Anonymous
    2020-06-11T13:46:10+00:00

    Can @Anna please respond since she is working at microsoft... ?!

    We are lots of people with the same issue... Jesus christ, can't be hard to get a real answer..

    Was this answer helpful?

    8 people found this answer helpful.
    0 comments No comments
  5. Anonymous
    2020-05-08T23:52:37+00:00

    Hello Adam,

    Given this situation, I consider you may login Outlook Web App with impacted account to see if emails can be sent.

    If Outlook Web App works well, then check firewall settings, anti-virus or related apps on your server and network, make sure all Office 365 related traffics are allowed: Office 365 URLs and IP address ranges, for some SMTP relay issues are caused by network settings.

    You may also refer to this article for troubleshooting: Fix issues with SMTP client submission.

    Besides, is there any organization-wide changes made recently? If convenient, use a different Office 365 account to see how it goes.

    Best Regards,

    Anna

    Hello Anna,

    I'm having the exact same issue currently.

    I have an older account (from January 2020, which is working perfect).

    I just got a new account & domain today, and for that one I get exactly the same error as Adam.

    I checked with the hosting provider, and no blocks at their end - so this is very strange.

    How should I go about it?

    Was this answer helpful?

    7 people found this answer helpful.
    0 comments No comments