I have the same problem as the original poster. On this laptop updates have worked perfectly for years and today I noticed that windows update has not completed the update check on it's own (there's a button saying check for updates).
If I do it manually, it just sits there saying checking for updates and meanwhile svchost.exe eats 1,5 GB of RAM and CPU load is 80 %. And it does not complete, ever. I have to kill the svchost process to be able to use the laptop.
What I have tried so far:
Windows Update error 0x80070005(2015-08-12-T-01_34_38P)
Fixed
Resetting Windows Update data store Completed
DataStoreAndWULogFiles.zip
35.13MB
File Name: DataStoreAndWULogFiles.zip
Error1
Access to the path 'C:\Windows\softwaredistribution' is denied.
Even though it says Fixed, there is an error (access is denied).
- The WindowsUpdate.log at C:\Windows gives no clues:
2015-08-12 15:05:33:507 6728
1ad4 Misc =========== Logging initialized (build: 7.6.7601.18804, tz: +0300) ===========
2015-08-12 15:05:33:507 6728 1ad4
Misc = Process: C:\Windows\system32\svchost.exe
2015-08-12 15:05:33:507 6728 1ad4
Misc = Module: c:\windows\system32\wuaueng.dll
2015-08-12 15:05:33:506 6728 1ad4
Service *************
2015-08-12 15:05:33:507 6728 1ad4
Service ** START ** Service: Service startup
2015-08-12 15:05:33:507 6728 1ad4
Service *********
2015-08-12 15:05:33:524 6728 1ad4
Agent * WU client version 7.6.7601.18804
2015-08-12 15:05:33:524 6728 1ad4
Agent * Base directory: C:\Windows\SoftwareDistribution
2015-08-12 15:05:33:528 6728 1ad4
Agent * Access type: No proxy
2015-08-12 15:05:33:529 6728 1ad4
Agent * Network state: Connected
2015-08-12 15:05:33:613 6728 1bf8
Report CWERReporter::Init succeeded
2015-08-12 15:05:33:613 6728 1bf8
Agent *********** Agent: Initializing Windows Update Agent ***********
2015-08-12 15:05:33:614 6728 1bf8
Agent * Prerequisite roots succeeded.
2015-08-12 15:05:33:614 6728 1bf8
Agent *********** Agent: Initializing global settings cache ***********
2015-08-12 15:05:33:614 6728 1bf8
Agent * WSUS server: <NULL>
2015-08-12 15:05:33:614 6728 1bf8
Agent * WSUS status server: <NULL>
2015-08-12 15:05:33:614 6728 1bf8
Agent * Target group: (Unassigned Computers)
2015-08-12 15:05:33:614 6728 1bf8
Agent * Windows Update access disabled: No
2015-08-12 15:05:33:615 6728 1bf8
DnldMgr Download manager restoring 0 downloads
2015-08-12 15:05:33:615 6728 1bf8
AU ########### AU: Initializing Automatic Updates ###########
2015-08-12 15:05:33:616 6728 1bf8
AU # AU disabled through User preference
2015-08-12 15:05:33:616 6728 1bf8
AU # Power management is turned off through policy
2015-08-12 15:05:33:616 6728 1bf8
AU Initializing featured updates
2015-08-12 15:05:33:616 6728 1bf8
AU Found 0 cached featured updates
2015-08-12 15:05:37:982 6728 1ad4
Report *********** Report: Initializing static reporting data ***********
(snip) the reporting data for the laptop hardware
2015-08-12 15:05:38:685 6728 1bf8
AU Successfully wrote event for AU health state:0
2015-08-12 15:05:38:734 6728 1bf8
AU Successfully wrote event for AU health state:0
2015-08-12 15:05:38:734 6728 1bf8
AU AU finished delayed initialization
That's it, no more log lines. Also, it says AU disabled due to user preference. That's because I disabled the automatic check because it just eats up the RAM and CPU every once in awhile.
Seems like the windows update version is 7.6.7600.320. Another thread suggests that this version is flawed in some way: http://answers.microsoft.com/en-us/windows/forum/all/new-windows-update-agent-767600320-causing-error/46b72f85-1fec-4445-877f-fc530510cba1
Please MS, how we are going to fix this?
Edit: More information, I checked "View Update History" and noticed that no updates other than definition updates for MSSE has been installed since July 21st this year. The last update was kb3079904.
Also, this may be connected to the issue that I couldn't change the windows update settings as to when to install/download updates. The setting was greyed out with a text "some settings are managed by your system administrator".
I am the sysadmin... Managed to get that setting open by editing local group policy. So maybe all this has something to do with losing adminstrator privileges...