Cannot start the Windows Event Log service on Local Computer. Error 4201: The instance name passed was not recognized as valid by a WMI data provider.
The renaming or deleting or changing the permissions of R tBackup did not fix this error for me,, after many weeks of testing and poking I found my solution , and I hope it helps others who haven't found a fix yet.
- Open the Registry and Navigate to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WMI\AutoLogger\
- Under this key are 3 EventLog- keys, each one has a DWORD(32) value called LogFileMode, if these aren't set correctly it causes the EventLog to fail to start with the 4201 Error. Here are the correct settings for each key...
\EventLog-Application\LogFileMode - value should be 11000180 (Hex)
\EventLog-Security\LogFileMode - value should be 100001c0 (Hex)
\EventLog-System\LogFileMode - value should be 10000180 (Hex)
Now reboot the PC and see if the eventlog service now starts
Good Luck