SERVER 2022: Random failures with: Windows Backup failed to get an exclusive lock on the EFI system partition (ESP)

Anonymous
2024-01-24T11:40:42+00:00

Various new fresh installations on HP and Dell ( mainly entry level servers) Windows server 2022 essentials set simple workgroup no domain or PDC etc...s various backup disks , tried secureboot on off tried AV removed / off (Defender) checked user its running as , removed and reinstalled backup etc etc

Nothing helps keep getting occasional Windows Backup failed to get an exclusive lock on the EFI system partition (ESP) and backup fails as it wont run

Thanks anyone who can help !

Windows for business | Windows Server | Storage high availability | Other

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments
Answer accepted by question author
Anonymous
2024-05-29T11:58:49+00:00

No, we run VMWare on Lenovo servers. EDIT: I've now also seen this problem on a Fujitsu server (no WMWare); random, about 1-2 times/month.

We haven't solved the issue through Microsoft support yet, but a workaround from MS has been applied, and there's been no WSB fails the last week.

(Note that in addition to this workaround, I wrote a script that checks the status of the VSS writers and writes it to a file, and is scheduled to run just before the WSB task, and 10 and 20 minutes into the task. Not that I can see why this would have any impact on the WSB task...)

Applied workaround:

  1. Open “Run” and enter “taskchd.msc” to launch Task Scheduler.
  2. Navigate to Microsoft/Windows/Backup
  3. Select Microsoft-Windows-WindowsBackup, right click, select properties and navigate to the Settings tab.
  4. Check the box “Allow task to be run on demand”
  5. You can try to select the box “If this task fails”. If this makes your backup work then you can stop here, if this doesn’t work follow the next steps.

 6. Click “OK“ to apply all the changes.

  1. Open cmd and type this command:

schtasks /create /F /RU SYSTEM /RL HIGHEST /SC onevent /EC Application /MO "*[System[Provider[@Name='Microsoft-Windows-Backup'] and (EventID=517)]]" /TN "Microsoft\Windows\Backup\Retry_Backup" /TR "schtasks /run /tn "Microsoft\Windows\Backup\Microsoft-Windows-WindowsBackup""

  1. Refresh the Backup folder in task scheduler.

 Note: on the command the “EventID = 517” section makes the scheduled task search for the backup failing with that event id. If for some reason the id changes then you’ll need to search for the new eventid in the event log and change it to the new eventid.

Was this answer helpful?

2 people found this answer helpful.
0 comments No comments

46 additional answers

Sort by: Most helpful
  1. Anonymous
    2024-05-29T13:28:44+00:00

    No, we run VMWare on Lenovo servers.

    We haven't solved the issue through Microsoft support yet, but a workaround from MS has been applied, and there's been no WSB fails the last week.

    (Note that in addition to this workaround, I wrote a script that checks the status of the VSS writers and writes it to a file, and is scheduled to run just before the WSB task, and 10 and 20 minutes into the task. Not that I can see why this would have any impact on the WSB task...)

    Applied workaround:

    1. Open “Run” and enter “taskchd.msc” to launch Task Scheduler.

     

    1. Navigate to Microsoft/Windows/Backup

              

    1. Select Microsoft-Windows-WindowsBackup, right click, select properties and navigate to the Settings tab.

     

    1. Check the box “Allow task to be run on demand”
    2. You can try to select the box “If this task fails”. If this makes your backup work then you can stop here, if this doesn’t work follow the next steps.

     

     6. Click “OK“ to apply all the changes.

     

    1. Open cmd and type this command:

    schtasks /create /F /RU SYSTEM /RL HIGHEST /SC onevent /EC Application /MO "*[System[Provider[@Name='Microsoft-Windows-Backup'] and (EventID=5)]]" /TN "Microsoft\Windows\Backup\Retry_Backup" /TR "schtasks /run /tn "Microsoft\Windows\Backup\Microsoft-Windows-WindowsBackup""

     

    1. Refresh the Backup folder in task scheduler.

              

     Note: on the command the “EventID = 5” section makes the scheduled task search for the backup failing with that event id. If for some reason the id changes then you’ll need to search for the new eventid in the event log and change it to the new eventid.

    Thanks for that I will try that in my case the failing backup id on the first 2 servers I check are Event ID *517* just FYI,

    Ps the first suggestion on retry on the actual task of the backup, I think, would only make a difference if the task failed to run in this instance the task it self executes , however the result is a fail , I had already tried this in the early days of this issue and thought better of it.

    Moving on to your second suggested task schedule looking for the explicit fail on backup running is a good idea and i will try it !!

    Was this answer helpful?

    0 comments No comments
  2. Anonymous
    2024-05-29T11:28:21+00:00

    Are all these servers that are having issues, Dell servers? Mine is. Poweredge 550.

    Was this answer helpful?

    0 comments No comments
  3. Anonymous
    2024-05-29T10:37:28+00:00

    I dont see the reboot issue you describe

    Was this answer helpful?

    0 comments No comments
  4. Anonymous
    2024-05-29T10:36:24+00:00

    Yes , I have found 99.9 % of the time the manual version runs however I have had some of them fail , run it again straight after a manual fail then it goes , its just got no logic to it

    Was this answer helpful?

    0 comments No comments