Fabric Workspace Private Link enabling issue on workspace

ajithgeenukunta 20 Reputation points
2026-09-15T14:36:36.18+00:00

We created a Private Link Service (PLS) using a custom deployment and then configured a Private Endpoint for the Fabric workspace, following the Microsoft documentation.

However, when attempting to enable Workspace-level Inbound Networking (Selected Networks + Workspace Private Links) on the Fabric workspace, we receive the following error:

{
 "errorCode": "InboundRestrictionNotEligible",
 "message": "The workspace might contain unsupported items, or the tenant-level setting 'Configure workspace-level inbound network rules' might be disabled."
}

We have already verified that the tenant-level setting "Configure workspace-level inbound network rules" is enabled. Despite this, the workspace continues to return the above error when enabling workspace-level inbound networking.

Could you help us determine whether there are any additional prerequisites, unsupported workspace items, or configuration requirements that could be causing this issue?

User's image

User's image

Community Center | Not monitored
0 comments No comments

2 answers

Sort by: Newest
  1. Gérard Oomens 131.8K Reputation points Volunteer Moderator
    2026-09-18T11:04:55.2633333+00:00

    Post/ask in the Fabric community:

    https://community.fabric.microsoft.com/

    Was this answer helpful?

    0 comments No comments

  2. Gulnaz Mushtaq 490 Reputation points MVP
    2026-09-15T18:20:56.1366667+00:00

    For InboundRestrictionNotEligible just the tenant setting alone is not sufficient but you have to check whether the workspace is on a Fabric F SKU and not a Trial/P SKU. Also check that whether "unsupported items" in the workspace are attached to a "Deployment Pipeline"

    Check by re-registering the Microsoft.Fabric resource provider in the Azure subscription because sometimes the resource provider isn't registered. Check that the PLS must use the exact Fabric workspace ID and tenant ID.

    Check that the Private Endpoint should target Microsoft.Fabric/privateLinkServicesForFabric with the sub resource workspace

    Allow ~15 minutes for propagation if the tenant setting was recently enabled.

    To diagnose properly, create an empty F-SKU workspace and try by enabling inbound networking. If it works fine then it means that the original workspace may have an unsupported configuration/item. If it doesn't work then check the tenant/PLS configuration.

    You can check the resource: https://learn.microsoft.com/en-us/fabric/security/security-workspace-level-private-links-set-up

    Was this answer helpful?

    0 comments No comments

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.