M365 and PIpedrive setup issues with 708 error

TRaG 190 Reputation points
2026-07-16T03:03:51.43+00:00

I have Microsoft 365 Business std license for the account and want to use Pipedrive for emails as well,

  1. as checked when sending the emails from the OWA to gmail there is no issues its working fine
  2. when I send an email from Pipedrive where in Microsoft 365 email account is setup, i get mail undelivered issue and error as
  3. Error Remote server returned '550 5.7.708 Service unavailable. Access denied, traffic not accepted from this IP.
  4. I have proper license for Pipedrive as well where its getting blocked? need help
Microsoft 365 and Office | Install, redeem, activate | For business | Other
0 comments No comments

Answer accepted by question author
Anonymous
2026-07-16T05:39:50.52+00:00

Hi TRaG

You’re seeing the 550 5.7.708 Service unavailable. Access denied, traffic not accepted from this IP error because Microsoft’s outbound mail protection is blocking traffic from your tenant or the IP address used by the integration.

If you’re on a trial subscription, this is expected behavior until licenses are assigned. In this case, I would recommend moving to a paid Microsoft 365 / Exchange Online subscription rather than relying on the trial tenant for production email sending.

After the paid licenses have been purchased and assigned, if outbound mail is still being blocked, the tenant administrator can then contact Microsoft Support and request an IP address exception for your tenant as mentioned in NDR error codes 550 5.7.703, 550 5.7.705, 550 5.7.708, and 550 5.7.750 - Microsoft Support(Only Microsoft Support can grant an IP exception, this cannot be resolved by tenant-side configuration alone).

User's image

For instructions on raising a support ticket, please refer to: Get support - Microsoft 365 admin | Microsoft Learn.

I hope this information is helpful and if you have any further question, please feel free to ask via comment section.

(Please understand that we're not Microsoft support, this is a user-to-user support forum. Moderators have no backend access and cannot directly intervene in Microsoft products. We provide only technical guidance and best-practice recommendations based on reported issues) 


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".   

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

Was this answer helpful?

2 people found this answer helpful.

0 additional answers

Sort by: Newest

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.