Unable to add a managed certificate to my Api Management resource

Niels Boesten 20 Reputation points
2026-07-09T10:33:08.4066667+00:00

Getting this error:
The HostnameConfiguration includes a new Managed Certificate Request, which is temporarily not supported during update from August 15th 2025 to June 30th 2026.

It's now july 9th, can we enable adding managed certificates again please.

Azure API Management
Azure API Management

An Azure service that provides a hybrid, multi-cloud management platform for APIs.

0 comments No comments

Answer accepted by question author
TP 163.5K Reputation points Volunteer Moderator
2026-07-09T10:39:16.9133333+00:00

Hi,

Unfortunately you currently cannot create a managed certificate for Azure API Management. You need to obtain a certificate for your custom domain from a trusted third-party provider and upload this for APIM. For example, you could obtain a free certificate from Let's Encrypt and upload the certificate and its private key (as .pfx file) to APIM. Or you could purchase a certificate and do the same thing.

Managed certificates functionality was supposed to be available again after March 15, 2026, then it was extended to June 30, 2026, but now that deadline has passed and it still isn't available.

Below article provides details on adding custom domain and uploading Custom certificate as .pfx file using portal:

Set a custom domain name - portal

https://learn.microsoft.com/en-us/azure/api-management/configure-custom-domain?tabs=custom#set-a-custom-domain-name---portal

Please click Accept Answer and upvote if the above was helpful.

Thanks.

-TP

Was this answer helpful?

1 person found this answer helpful.

0 additional answers

Sort by: Most helpful

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.