Logic App ServerFarmCreationNotAllowed Error

Robert Kerber 20 Reputation points
2026-07-05T15:07:51.3+00:00

I am trying to deploy an Azure Logic App (Standard) using the WS1 Workflow Standard tier in East US 2 via the Portal. My quota for WorkflowStandard indicates ample availability, and the Microsoft.Web provider is fully registered. However, the preflight check fails immediately with error code ServerFarmCreationNotAllowed. I've tried a variety of different configurations of the Logic App Deployment and none of the setting changes make a difference.

Here's the full error i'm getting.

{ 'deploymentStatusCode': -1, 'stage': 6, 'expected': true, 'error': { 'code': 'InvalidTemplateDeployment', 'details': [ { 'code': 'ValidationForResourceFailed', 'message': 'Validation failed for a resource. Check 'Error.Details[0]' for more information.', 'details': [ { 'code': 'ServerFarmCreationNotAllowed', 'message': 'The subscription 'subid' is not allowed to create or update the serverfarm.' } ] } ], 'message': 'The template deployment 'Microsoft.Web-LogicApp-Portal-0210b1c8-b291' is not valid according to the validation procedure. The following resource provider(s) - 'Microsoft.Web/serverFarms (2024-11-01)' reported preflight validation errors. Tracking id is '70f5c370-0883-477f-a3ed-228e5824fb95'. See inner errors for details.' }, 'subscriptionId': 'subid', 'resourceGroupName': 'EU2P-SERVICE-RG', 'location': 'East US 2', 'deploymentName': 'Microsoft.Web-LogicApp-Portal-0210b1c8-b291', 'details': { 'code': 'InvalidTemplateDeployment', 'message': 'The template deployment 'Microsoft.Web-LogicApp-Portal-0210b1c8-b291' is not valid according to the validation procedure. The following resource provider(s) - 'Microsoft.Web/serverFarms (2024-11-01)' reported preflight validation errors. Tracking id is '70f5c370-0883-477f-a3ed-228e5824fb95'. See inner errors for details.', 'details': [ { 'code': 'ValidationForResourceFailed', 'message': 'Validation failed for a resource. Check 'Error.Details[0]' for more information.', 'details': [ { 'code': 'ServerFarmCreationNotAllowed', 'message': 'The subscription 'subid' is not allowed to create or update the serverfarm.' } ] } ] }, 'notificationTimestamp': '2026-07-05T14:21:19.072Z' }

Azure Logic Apps
Azure Logic Apps

An Azure service that automates the access and use of data across clouds without writing code.

0 comments No comments

Answer accepted by question author
Rakesh Mishra 11,340 Reputation points Microsoft External Staff Moderator
2026-07-05T16:06:30.81+00:00

Hi Robert, meanwhile we were looking into the issue, you were able to deploy successfully without any issues.

This may happen due to Azure's internal mechanism to prevent resource abuse via automated scripts. That is why it blocked you temporarily and then creation was allowed after some time.

Please do let me know if any further question on this or any issues.

Was this answer helpful?

1 person found this answer helpful.

0 additional answers

Sort by: Most helpful

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.