Azure Data Factory linked services ClientIPNotAuthorized

Felix Fung 0 Reputation points Microsoft Employee
2026-06-29T22:38:59.2633333+00:00

Nothing changed on our pipeline/resources

The linked services and publishing fail with

Failed to get DataPlane access, reason: {"code":"ClientIPNotAuthorized","message":"Client IP not authorized to access the API. Please ensure you are on corpnet, or that your IP is on an allowlist for the activities in your pipeline.","target":null,"details":null}

Our linked services link to both on-prem SQL DB and Azure SQL DB, so this is unlikely a config error on our end.

Azure Data Factory
Azure Data Factory

An Azure service for ingesting, preparing, and transforming data at scale.


Answer recommended by moderator
Felix Fung 0 Reputation points Microsoft Employee
2026-06-30T20:05:21.4366667+00:00

The problem resolved itself without intervention

Was this answer helpful?

0 comments No comments

2 additional answers

Sort by: Oldest
  1. Nandan Hegde 36,966 Reputation points MVP Volunteer Moderator
    2026-06-30T06:24:18.6566667+00:00

    Can you confirm what is the Network settings property for your ADF?
    User's image

    probably some changes might have been done.

    Was this answer helpful?


  2. Felix Fung 0 Reputation points Microsoft Employee
    2026-06-30T18:39:39.6666667+00:00

    Problem resolved. Transient issue

    Was this answer helpful?

    0 comments No comments

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.