Azure Database for MySQL Flexible Server - list-skus returns HTTP 500 (locations/capabilities) for all regions

HF 20 Reputation points
2026-06-29T20:56:44.3933333+00:00

Hi

Cannot create Azure Database for MySQL Flexible Server or perform PITR restore.

Resource provider Microsoft.DBforMySQL: Registered

Subscription state: Enabled

Portal fails with:

ProvisionNotSupportedForRegion

Azure CLI fails before provisioning when calling:

GET /subscriptions/.../providers/Microsoft.DBforMySQL/locations/eastus/capabilities?api-version=2025-06-01-preview

The endpoint returns:

HTTP 500 InternalServerError

Tracking IDs:

bb2c6691-46af-4525-af24-135207ed9dac

203189ec-8ac4-406c-8954-a0b1e6f31889

2cc51ed8-fb71-4d09-9939-3b3a31967b2e

7fbb10fd-6712-44dd-8351-d95e22cd4308

Quota was already increased.

VM creation in Brazil South works.

Issue happens in Brazil South and East US.

Any idea?

Azure Database for MySQL

Answer accepted by question author
TP 163.6K Reputation points Volunteer Moderator
2026-06-29T22:02:08.79+00:00

Hi,

A response of 500 InternalServerError when calling Location Based Capability Set - Get means that your subscription is blocked from provisioning in that region (East US in this case). Due to capacity limitations a large number of subscriptions have been blocked from deploying MySQL Flexible Server to the most popular regions (East US is one).

One thing you try is to create a free Service and subscription limits (quotas) request and request access to and/or increase your MySQL Flexible quota for East US region.

To start the process, please click link below:

https://portal.azure.com/#create/Microsoft.Support

Issue type: Service and subscription limits (quotas)

Quota type: Azure Database for MySQL Flexible Server

Click Next

On Additional details tab, click Enter details. Select Region access or Quota increase, select region, select other details as needed, Save. Continue filling out Additional details tab, click Next, review and Create the case. You should receive automated email within minutes.

If you already have MySQL Flexible Server in East US you could use Cross Region Restore to restore database to different region, one that is not currently blocked.

If you have any questions please add a comment below.

Please click Accept Answer and upvote if the above was helpful.

Thanks.

-TP

Was this answer helpful?

1 person found this answer helpful.

0 additional answers

Sort by: Oldest

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.