Unable to create Azure Managed Redis in Central US or East US 2 region despite those regions are already available

Alyssa Vu 20 Reputation points Microsoft Employee
2026-06-24T00:37:39.9333333+00:00

I kept getting error saying the creation reached terminal state of "Failed" without any clear message about what caused the failure:

{
  "code": "DeploymentFailed",
  "target": "/subscriptions/xxx/resourceGroups/ray-example-rg/providers/Microsoft.Resources/deployments/CreateRedisEnterprise-ray-gcs-20260623172758",
  "message": "At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-deployment-operations for usage details.",
  "details": [
    {
      "code": "ResourceDeploymentFailure",
      "target": "/subscriptions/xxx/resourceGroups/ray-example-rg/providers/Microsoft.Cache/redisEnterprise/ray-gcs",
      "message": "The resource write operation failed to complete successfully, because it reached terminal provisioning state 'Failed'."
    }
  ]
}
Azure Cache for Redis
Azure Cache for Redis

An Azure service that provides access to a secure, dedicated Redis cache, managed by Microsoft.

0 comments No comments

Answer accepted by question author
Pilladi Padma Sai Manisha 11,715 Reputation points Microsoft External Staff Moderator
2026-06-24T01:23:55.8966667+00:00

Hi @Alyssa Vu
Thankyou for reaching Microsoft Q&A!
As this related quota issue, please try in different region like west us region
and follow below document for quota increase:
1. Navigate to this link to start the process:

https://portal.azure.com/#create/Microsoft.Support

2. Enter quota in the box and click Go

 

3. Select Others / Service and subscription limits (quotas) and click Next

 

4. Click Create a support request button, as shown

 

5. Select Issue type: Service and subscription limits (quotas), Subscription, Quota type: Azure Database for MySQL Flexible Server, click Next

 

6. Now you should be on Additional details tab. Click Enter details

 

7. Select Region access or Region access with zonal dependency, select Location you need, enter number of cores needed, click Save and continue

 

8. Finish filling out Additional details tab, click Next, review and click Create. You should receive an automated email within a few minutes.

 

Was this answer helpful?

1 person found this answer helpful.
0 comments No comments

0 additional answers

Sort by: Most helpful

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.