How to fix error: your message can't be sent because your tenant exceeded limit

Mhlarhi, Rirhandzu 20 Reputation points
2026-06-15T09:31:47.92+00:00

Error: Remote server returned "550 5.7.236' Your message can't be sent because your tenant exceeded it's daily limit for sending to external recipients from your onmicrosoft.com domains

Exchange Online
Exchange Online

A cloud-based service included in Microsoft 365, delivering scalable messaging and collaboration features with simplified management and automatic updates.

0 comments No comments

Answer accepted by question author
Anonymous
2026-06-15T10:06:16.4933333+00:00

Hi  Mhlarhi, Rirhandzu

Based on my research, it seems that you are reaching the sending limit to external recipients when using the onmicrosoft domain within a 24-hour window.

For your reference, you may find more details in this article: Email nondelivery reports (NDRs) and SMTP errors in Exchange Online - Exchange | Microsoft Learn 

 User's image

As recommended, it would be advisable to consider using your custom domain for production and commercial purposes. This approach can help ensure a more consistent and reliable experience when sending emails externally. 

For more details on setting up a custom domain, you may refer to: Add a Custom Domain to Microsoft 365 - Microsoft 365 admin | Microsoft Learn 

 

I hope this brings helpful insight. 


If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment". 

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

Was this answer helpful?

3 people found this answer helpful.

0 additional answers

Sort by: Newest

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.