In dev.azure, user's access level is automatically changing to stakeholder from Basic. Duplicate identity causing 500 login error and infinite license loop in Azure DevOps

Nirbhay Giri 40 Reputation points
2026-06-10T07:04:49.68+00:00

Organization: ACPLApps (dev.azure.com/ACPLApps)

Affected users:



Problem:

Audit logs show "Duplicate identity found" every 30 seconds.

Azure DevOps Service automatically removes Basic license and

assigns Stakeholder in a loop. Users cannot login - 500 error.

Already done:

  • Permanently deleted old identities from Microsoft Entra
  • Removed and re-added users multiple times
  • Ghost identity still persists in Azure DevOps backend

Need backend identity/descriptor cleanup for these users.

Azure DevOps

Answer accepted by question author
Siddhesh Desai 8,210 Reputation points Microsoft External Staff Moderator
2026-06-10T07:27:18.2166667+00:00

Hi @Nirbhay Giri

Thank you for reaching out to Microsoft Q&A.

As per the discussion on Teams chat the backend team helped resolve the issue.

If the resolution was helpful, kindly take a moment to click on 210246-screenshot-2021-12-10-121802.pngand click on Yes for was this answer helpful. And, if you have any further query do let us know.

Was this answer helpful?

2 people found this answer helpful.

0 additional answers

Sort by: Newest

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.