Provisioning in requested region is not supported. Your subscription might not have access to create a server in the selected region. (https://aka.ms/mysqlcapacity) (Code: ProvisionNotSupportedForRegion)

Carl Taylor 20 Reputation points
2026-06-02T10:16:27.75+00:00

I am attempting to update our MySQL Flexible resource to MySQL 8 in the UK South region but I get the following error "Provisioning in requested region is not supported. Your subscription might not have access to create a server in the selected region. (https://aka.ms/mysqlcapacity) (Code: ProvisionNotSupportedForRegion)" and am unable to provision any resources of this kind in the region even though they are available and we already have similar resources deployed in the same region

Azure Database for MySQL

Answer accepted by question author
Manoj Kumar Boyini 19,590 Reputation points Microsoft External Staff Moderator
2026-06-02T11:03:03.79+00:00

Hi @Carl Taylor

Request region access

Go to Create a Support Request

Choose: Service and subscription limits (quotas)

Select: Azure Database for MySQL Flexible Server

Under Additional details:

  • Choose Region access
  • Select required region and cores

Submit the request.

Please let us know if you have any questions or concerns

Was this answer helpful?

1 person found this answer helpful.
0 comments No comments

0 additional answers

Sort by: Most helpful

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.