A cloud-based identity and access management service for securing user authentication and resource access
Cannot sign in automatically to subscription Error: AADSTS5000225
Hi everyone,
I am encountering an apparently common error that happens when you have a deleted/blocked tenant due to inactivity.
I am getting the error AADSTS5000225 whenever I try to login to Azure or azure system normally. Below is the latest error in a string of them:
mssql: ServerError: invalid_grant: Error(s): 5000225 - Timestamp: 2026-02-04 11:43:09Z - Description: AADSTS5000225: This tenant has been blocked due to inactivity. To learn more about tenant lifecycle policies, see https://aka.ms/TenantLifecycle Trace ID: 7932ea9c-0fec-473a-8a28-8f4c58af1600 Correlation ID: ba4fb94e-5729-4bc8-a1fc-17a9199ae2d0 Timestamp: 2026-02-04 11:43:09Z - Correlation ID: ba4fb94e-5729-4bc8-a1fc-17a9199ae2d0 - Trace ID: 7932ea9c-0fec-473a-8a28-8f4c58af1600
I have another tenant and I can login-to it successfully through a web-browser because I can specify the domain https://portal.azure.com/<Working Domain Name>. I tried removing the link both by trying to leave the tenant or deleting said tenant from the directory selection page. In both cases, Azure tries to move me to that directory and I get the error above again.
Can anyone help me with this?