Can't login to Azure Portal to create a new Tenant

Julio Gutierrez 0 Reputation points
2026-01-08T20:01:36.4066667+00:00

I got this error

AADSTS5000225: This tenant has been blocked due to inactivity. To learn more about tenant lifecycle policies.........

After reviewing and researching it, the tenant had exceed the 20 days inactivity policy and therefore deleted.
If I can't log into the Azure Portal I can't create a new one.

Tried Microsoft Public Support for help and ended up here.

Please advise

JCG

Microsoft Security | Microsoft Entra | Microsoft Entra ID

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.