APIM not able to connect to Load Balancer even though they all are on the Public IP

Kartik Mahajan CONSULTANT 0 Reputation points
2025-11-17T18:15:04.9833333+00:00

APIM not able to connect to Load Balancer even though they all are on the Public IP

APIM Public IP .

LB frontend Public IP 20.***.***31

Backend pool -- 10.*.4 / 5 / 6 --- All healthy via probe Service Listening on '8096'  --- netstat -tulnp | grep 8096 confirms it

Firewall rules -> Inbound - az_sitaA_dev_apim_to_LB_rh9 (APIM → LB)  az_sitaA_dev_api_lb_rh9_to_rh9_docker

(LB → backend servers) Test from backend VM → LB public IP ---  times out --- curl http://LB Public IP:8096(Note it is not working from RHEL 7 servers too)

Test from backend VM → APIM public IP --- works --- curl -v http://APIM public IP

 

When doing the GET API call Trace test from APIM gets error - forward-request (21,044.392 ms) {     "messages": [         "Unable to connect to the remote server",         "Error occured while calling backend service.",         "A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond LB Public IP:8096"    ] }

Azure Load Balancer
Azure Load Balancer

An Azure service that delivers high availability and network performance to applications.


Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.