Azure PostgreSQL Flexible Server “Unavailable” after subscription reactivation

Diego Armas 0 Reputation points
2025-10-25T22:46:33.16+00:00

Hello community,

I am experiencing a critical issue with an Azure Database for PostgreSQL – Flexible Server and need guidance:

Situation:

  1. The subscription was previously suspended due to non-payment, and the payment has now been completed.

The server still shows as Unavailable, and it is not possible to connect via SQL or CLI commands.

I tried performing a stop/restart, but received the following error:

Cannot perform 'Stop' server operation because server is busy processing other operation (ServerBusyWithOtherOperation)

Resource Health indicates:

Current status: Available

Event type: Downtime

Cause: PlatformInitiated

Details: “An unexpected problem is preventing restoring access to the server. Platform is working on resolving the problem.”

Impact: The server is inaccessible, CPU and RAM metrics show 0, and any manual operation fails.

Question: Is there a way to force the server to reactivate or accelerate the internal operation that is blocking access?

Any guidance or recommendations would be greatly appreciated. Thank you!Hello community,

I am experiencing a critical issue with an Azure Database for PostgreSQL – Flexible Server and need guidance:

Situation:

The subscription was previously suspended due to non-payment, and the payment has now been completed.

The server still shows as Unavailable, and it is not possible to connect via SQL or CLI commands.

I tried performing a stop/restart, but received the following error:

Cannot 

Resource Health indicates:

Current status: Available

Event type: Downtime

Cause: PlatformInitiated

Details: “An unexpected problem is preventing restoring access to the server. Platform is working on resolving the problem.”

Impact:
The server is inaccessible, CPU and RAM metrics show 0, and any manual operation fails.

Question:
Is there a way to force the server to reactivate or accelerate the internal operation that is blocking access?

Any guidance or recommendations would be greatly appreciated. Thank you!

Azure Database for PostgreSQL

Your answer

Answers can be marked as 'Accepted' by the question author and 'Recommended' by moderators, which helps users know the answer solved the author's problem.