An Azure NoSQL database service for app development.
Unable to run pg_partman jobs due to lost permissions on admin account
Hello I had two threads on this issue that did not reach a resolution: https://learn.microsoft.com/en-us/answers/questions/4376274/unable-to-run-pg-partman-jobs-due-to-lost-permissi
This is the 3rd thread on this issue
I am using pg_partman to manage partitions. My admin account lost permission to access partman.part_config and cannot run partition jobs anymore and I am unable to grant permission to the table manually for that user. How can I fix this issue and regain use of this extension
working with the Support Person in the previous thread lead to some suggestions on adding permissions to my admin role
Most recent suggestion was
DROP EXTENSION pg_partman CASCADE;
CREATE EXTENSION pg_partman SCHEMA partman;
which attempting gave me
citus=> DROP EXTENSION pg_partman CASCADE;
ERROR: must be owner of extension pg_partman
at this point I am out of ideas; I think i just need someone with root access to disable and enable to extension or just give my admin account permissions to the extension