KB5066835 update causing IIS Service to not work

Sashi Kumar 405 Reputation points
2025-10-15T10:06:37.1166667+00:00

Recently my local hosted IIS services is not running after the new update. My visual studio projects also can't be run as well. I have to delete the new update in order to run my projects and local hosted services again. May I know what is the problem?

Developer technologies | ASP.NET Core | Other

Locked Question. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

Answer accepted by question author
xavier ubikos 175 Reputation points
2025-10-16T05:23:40.57+00:00

Hi there!

This morning there was a Defender update, I have installed it an now it works!!!

Was this answer helpful?

20+ people found this answer helpful.

50 additional answers

Sort by: Oldest
  1. MK-5121 5 Reputation points
    2025-10-15T17:32:52.4266667+00:00

    Having the same issues IIS stops working all development stops working for our projects and the issue is also uninstall failed as well. Good job Microsoft!!!

    Multi-billion dollar company and they're pushing updates like they're bunch of kids in the garage!!!

    Was this answer helpful?

    1 person found this answer helpful.
    0 comments No comments
  2. Wiktor Zychla 0 Reputation points
    2025-10-15T19:09:01.58+00:00

    Affected also, IIS doesn't work, IIS express doesn't work.

    Using .NET since the very beginning and I don't really remember such serious fail for all these years.

    Shame on anyone who approved this update to be released.

    Was this answer helpful?

    0 comments No comments
  3. Brent Long 11 Reputation points
    2025-10-15T19:33:48.8666667+00:00

    Same. Had to uninstall KB5066835.

    Was this answer helpful?

    1 person found this answer helpful.
    0 comments No comments
  4. MoutonJB 0 Reputation points
    2025-10-15T19:40:49.6566667+00:00

    I have the same issue, both IIS and IIS Express affected. I am unable to uninstall KB5066835 using any of the mentioned uninstall procedures even though I can see the update in my update history. I also have no success after disabling HTTP/2 on IIS or via the registry.

    Was this answer helpful?