An Azure service that provides an event-driven serverless compute platform.
Why is my API access attempt returning an error message containing an unknown app ID?
We have an on-premises system trying to access dynamics monitoring data using an enterprise app. The app has the permissions advised by the on-premises software editor and the propoer id and keys have been used.
We get this error:
== Info: TLSv1.3 (IN), TLS handshake, [no content] (0): == Info: TLSv1.3 (IN), TLS handshake, Newsession Ticket (4): == Info: TLSv1.3 (IN), TLS app data, [no content] (0): => Recv header: HTTP/1.1 403 Forbidden => Recv header: Cache-Control: no-cache => Recv header: Pragma: no-cache => Recv header: Content-Length: 492 => Recv header: Content-Type: application/json; charset=utf-8 => Recv header: Expires: -1 => Recv header: x-ms-failure-cause: gateway => Recv header: x-ms-request-id: a1163876-2767-451b-8007-bb1847695dc0 => Recv header: x-ms-correlation-request-id: a1163876-2767-451b-8007-bb1847695dc0 => Recv header: x-ms-routing-request-id: AUSTRALIAEAST:20250910T012945Z:a1163876-2767-451b-8007-bb1847695dc0 => Recv header: Strict-Transport-Security: max-age=31536000; includeSubDomains => Recv header: X-Content-Type-Options: nosniff => Recv header: X-Cache: CONFIG_NOCACHE => Recv header: X-MSEdge-Ref: Ref A: 6164246C614B4B6B9A744C1E3469D1DB Ref B: SYD03EDGE2022 Ref C: 2025-09-10T01:29:45Z => Recv header: Date: Wed, 10 Sep 2025 01:29:45 GMT => Recv header: => Recv data: {"error":{"code":"AuthorizationFailed","message":"The client 'cf3ea12d-d4b2-4d31-be9d-4834c989d1a1' with object id 'cf3ea12d-d4b2-4d31-be9d-4834c989d1a1' does not have authorization to perform action 'microsoft.insights/metrics/read' over scope '/subscriptions/0d84438e-9f80-4266-aab4-04aba360cbc1/resourceGroups/CRM-DEV/providers/Microsoft.ApiManagement/service/BSSPRD/providers/microsoft.insights' or the scope is invalid. If access was recently granted, please refresh your credentials."}} == Info: Connection #0 to host management.azure.com left intact Error message : The client 'cf3ea12d-d4b2-4d31-be9d-4834c989d1a1' with object id 'cf3ea12d-d4b2-4d31-be9d-4834c989d1a1' does not have authorization to perform action 'microsoft.insights/metrics/read' over scope '/subscriptions/0d84438e-9f80-4266-aab4-04aba360cbc1/resourceGroups/CRM-DEV/providers/Microsoft.ApiManagement/service/BSSPRD/providers/microsoft.insights' or the scope is invalid. If access was recently granted, please refresh your credentials.
This ID does not match anything in our tenant.
cf3ea12d-d4b2-4d31-be9d-4834c989d1a1
What is it?
The softwre editor advises we raise a ticket with MSFT support as they cannot explain this error.