An Azure NoSQL database service for app development.
Unable to run pg_partman jobs due to lost permissions on admin account to extension tables
Hello I had a previous thread on this issue that did not reach a resolution: https://learn.microsoft.com/en-us/answers/questions/4376274/unable-to-run-pg-partman-jobs-due-to-lost-permissi
The original issue was
I am using pg_partman to manage partitions. My admin account lost permission to access partman.part_config and cannot run partition jobs anymore and I am unable to grant permission to the table manually for that user. How can I fix this issue and regain use of this extension
working with the Support Person in the previous thread lead to some suggestions on adding permissions to my admin role
GRANT ALL PRIVILEGES ON partman.part_config TO your_admin_role;
However attempting to access the pg_partman.part_config table throws errors.
citus=> select * from partman.part_config;
ERROR: permission denied for table part_config
citus=> GRANT SELECT ON SCHEMA partman TO citus;
ERROR: invalid privilege type SELECT for schema
citus=> GRANT ALL ON SCHEMA partman TO citus;
GRANT
citus=> SELECT * from partman.part_config;
ERROR: permission denied for table part_config
citus=>