Pipelines are stuck in queued status after connecting to the Organization to Entra
Pipelines are stuck in queued status after connecting the Organization to Entra. The Pipeline never runs and gets the following error:
##[error]The request: 447 was abandoned due to an infrastructure failure. Notification of assignment to an agent was never received.
We have completed all the suggestions on the support and help page. They still will not run. The pipelines worked fine before connecting to Entra.
Host agent is online and enabled.
Region is Switzerland.
We have free trier 1 parallel job.
We have completed and checked all suggestions:
Make sure you haven't exceeded the parallel job limits.
Make sure your jobs aren't waiting for approval.
Check the agent pools page to see if all your available agents are in use.
Check the Azure DevOps status page to make sure there aren't any ongoing or past incidents in Azure Pipelines.
This error might happen if you've removed the Agent Pool Service (xx) user from Organization Settings > Permissions > Security Service Group. The Agent Pool Service (xx) user is unique for each project. You can also check the auditing logs to see if this user was removed from the group. If the user has been removed, add the user back to the group.
Removed and re-added the users and groups needed from the Pipeline Security and Agent
Azure DevOps
1 answer
Sort by: Oldest
-
Deleted
This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.
1 deleted comment
Comments have been turned off. Learn more