A family of Microsoft relational database management systems designed for ease of use.
Thanks for that George!
This browser is no longer supported.
Upgrade to Microsoft Edge to take advantage of the latest features, security updates, and technical support.
I had a client today who could not open their shared backend database. The system displayed the error “Could not lock file”.
I determined that Access was trying to open the file in exclusive mode, even though none of the normal methods to open the file exclusively were being applied:
• The File / Options / Client Settings / Advanced / Default open mode was set to Shared
• No command line /excl was being used
• The user had Full Control permissions for the shared folder containing the database
• Creating a new test database opened it exclusively, so that no other user could open it.
• The newly created test database could not be reopened if another user opened it,
• Several other users could simultaneously open the new test database without a problem.
The user had been using the database for normal operations for several days prior to the problem.
The user’s system has updated to build 16.0.14701.20248 today.
All other test users had build 16.0.14701.20226.
I rolled the user's Office installation back to 16.0.14701.20226 by using the Office Deployment Tool https://support.microsoft.com/en-us/topic/how-to-revert-to-an-earlier-version-of-office-2bd5c457-a917-d57e-35a1-f709e3dda841
The problem was solved.
Can anyone else confirm that this problem exists with the latest build of Access?
Neil Sargent
Smart IT Ltd
A family of Microsoft relational database management systems designed for ease of use.
Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.
Thanks for that George!
@TylerWilliams_14
Check George's link as it covers the subject and provides the workaround (hint: rollback/uninstall the latest update).
Keep an eye on Daniel's blog and on this MS page.
Similar issue myself as I attempted to even relocate the back end into another shared location but it acted as if my URL for the location was incorrect or did not exist. Hoping to get a real resolution soon as rolling back the update isn't seeming like viable option for us.
Having same issue here. Small business with only five users, but one suddenly could not use Access database unless all other users were not using it. Noticed when that user was connected the locking file was 0db and empty. Search led me to this thread which led me to checking the software versions and confirm issue is the same. Have not reverted the users version yet, but assume it would fix it.