Using Classic Outlook on Windows for personal email, calendar, and contact management
I went through a support ticket with Microsoft, and the problem was resolved. I understand why, and it's not that complicated.
Yahoo and certain other email providers have started or are about to enforce a rule that sending domains (domains, not email providers) have a valid SPF record. They are also claiming to require DMARC and DKIM, but the real issue for now seems to be SPF. See https://www.proofpoint.com/us/blog/email-and-cloud-threats/google-and-yahoo-set-new-email-authentication-requirements for details.
In my case, my email provider is Microsoft, but my domain registrar is Google. It is at the Google Domains DNS that we made the change. My SPF record had a stupid error in it that I should have seen myself. It's common for domains to have more than one SPF record, so it must be changed if that is the case with yours.
I do wish that a more informative error message was used than the failed socket, but this seems to be the source of the problem.
If you don't know your way around DNS, then, as the user to whom I'm replying says, you can seriously bork all your systems. Have a qualified admin do it, or ask Microsoft support for help.