We have encountered the same issue with 'Cannot send this item' errors appearing when replying\forwarding messages.
It appears to happen when the message content contains a chain of messages, which will have URLs in signatures that have been rewritten by Sophos Mail Gateway. One suggestion has been to turn off the URL rewriting but we have yet to test this.
I have, however, just tested a message from an eml file which was unable to send, and unfortunately the latest beta channel build 13919.20002 does not appear to fix this issue. The same 'Cannot send this item' appears.
What the root cause appears to be is either the number of URLs in the message body, or the combined length of all URLs - since rewritten URLs tend to be of a considerable length. I'm hoping to test this next by replacing previously rewritten URLs and testing. The combined length appears to be more likely as removing longest URLs first one by one until the message sends appears to resolve the issue with less removed than removing shorter URLs.
Many thanks,
--Richard Allan