Kenneth I am sure that in my case the service was not actually operational and was in fact in an error state. I dismissed that error and rebooted. It came back. It was persistent.
The root cause was that the security update enabled LSA (per fg2001) and for it to run core virtualization (SVM) MUST be enabled in the system BIOS. My system did not have the option turned on and therefore LSA did not operate. In fact, I couldn't even get to the core isolation option to turn it on or off because for that to present on your client you need SVM enabled.
That was the situation with my own client anyway.
My complaint was that MS enabled LSA in this update, it requires SVM, and can put users in the situation I was. With very little to go on for determining root cause.