I'm having the same issue on new install of Windows 10 x64 1809 Enterprise (fully patched as of 11/23/18) in vSphere 6.7 Update 1. I'm moving the paging file off the C drive to a D drive for Citrix PVS 1808.
My VM had 4GB of RAM.
I usually set the paging file the same as the RAM so min 4096 MB and max 4096 MB. When I boot up, i get the created temporary page file error, and when i check there's a 1406 MB paging file on the C drive. Even if i set the paging file to 2x the RAM at min 8192 MB and max 8192 MB I experience the same behavior.
I experience the exact same behavior in Server 2019, so it seems like its something with the 1809 codebase. Hopefully its resolved soon.