Error 87 running "DISM /Online /Cleanup-Image /RestoreHealth" on Windows 7.

Anonymous
2013-12-07T03:40:05+00:00

I followed some advice on the wiki System file check (SFC) Scan and Repair System Files to find out how to fix corrupted files that SFC couldn't (as I had previously already known about SFC) and came across this barrier.

Here is a log file of DISM, if you need. It includes information only from the execution of DISM described in this thread.

Also, in case you need it, is my Command Prompt. Instead of creating a screenshot, I just pasted it in plain text.

Microsoft Windows [Version 6.1.7601]

Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\system32>DISM /Online /Cleanup-Image /RestoreHealth

Deployment Image Servicing and Management tool

Version: 6.1.7600.16385

Image Version: 6.1.7600.16385

Error: 87

The restorehealth option is not recognized in this context.

For more information, refer to the help.

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

Windows for home | Previous Windows versions | Windows update

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments
Answer accepted by question author
Anonymous
2014-06-17T01:51:15+00:00

Hello, joel perry

     The TechNet Library article "DISM Supported Platforms" notes that "...Some DISM commands are not supported on all target images. For information about specific DISM commands, see Deployment Image Servicing and Management (DISM) Command-Line Options."; an admittedly-perfunctory perusal of the multiple articles linked in that one fails to reveal at a glance exactly what commands are supported by what OS, unfortunately - the documentation seems to follow the "new norm" of minimalization.  "[DISM

  1. ".../AnalyzeComponentStore and /ResetBase can’t be used when servicing a version of Windows that is earlier than Windows 8.1 or Windows Server 2012 R2 images."
  2. ".../StartComponentCleanup can’t be used when servicing a version of Windows that is earlier than Windows 8 or Windows Server 2012 images.", and
  3. ".../CheckHealth, /ScanHealth, /RestoreHealth, /Source, and /LimitAccess can’t be used when servicing a version of Windows that is earlier than Windows 8 or Windows Server 2012 images"

What is DISM?" mentions that "...To service inbox drivers in an offline image of Windows Vista with Service Pack 2 (SP2) or Windows Server 2008 with SP2, you must use the Windows 7 version of DISM or PkgMgr."

while "DISM Supported Platforms" also provides this: "Deployment Image Servicing and Management (DISM) works on Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server® 2012, Windows 7, and Windows Server 2008 R2 images. However, the full functionality is available only when you are servicing a Windows 8.1 or Windows Server 2012 R2 image. This is because the files and resources required to service any Windows image are located in the image, not on the technician computer. DISM will detect and use the resources available in the target image to update the image."

     Although by no means a WIM-deployment professional myself, it would seem to me that you're presented with the limited options you're seeing simply because nothing else is supported by design,

and that using a later version of DISM (as outlined in "Copy DISM to Another Computer", which maintains that "...You can use deployment and imaging tools on a supported host operating system, such as Windows PE 3.0, even if you cannot install Windows ADK. You can copy the tools from a Windows ADK installation on your technician computer and configure the tools for use on a supported host computer.") would not provide the missing functionality...

Was this answer helpful?

200+ people found this answer helpful.
0 comments No comments

54 additional answers

Sort by: Most helpful
  1. Anonymous
    2018-09-17T16:32:28+00:00

    believe me, it was entered correctly. something else is wrong!

    Was this answer helpful?

    1 person found this answer helpful.
    0 comments No comments
  2. Anonymous
    2018-09-17T11:41:06+00:00

    Cameron

    The only time I have seem error 87 is when the spaces were forgotten

    You are just entering the command incorrectly. It should be this below with the spaces instead:

    Dism /Online /Cleanup-Image /RestoreHealth(note the space after 'dism" & "online" & "image")

    Hello,

    I ran it as Administrator as you suggested...in fact I copied and pasted it, and STILL got the Error 87.

    Thanks,

    Tom

    Was this answer helpful?

    1 person found this answer helpful.
    0 comments No comments
  3. Anonymous
    2014-06-17T15:57:33+00:00

    You are awesome, Thank you very much. now I just have to find a way to perform this action manually then (just kidding, that would take a lot more time than it is worth), as I have been informed it is the only resolution to the SCCM 2012 CU3 error message I'm receiving on multiple servers...  but that is not a thing for this thread :)  If my companies contract did not end July 31st, I'd open a Microsoft case to resolve these now that I know the resolution is not viable.  I'll instead pass the info on to the person who is interested with the IT company that is replacing us.  Too many other things to do in the remaining time to worry about the dozen or so servers I was hoping to get this running on in the next couple weeks.  I have 400-600 more servers that need other problems resolved too  :)

    Was this answer helpful?

    0 comments No comments
  4. Deleted

    This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.


    Comments have been turned off. Learn more