My tests indicated that it is not just any Linux or Unix based NAS devices that are having problems. Prior to adding a new Windows 8 Pro computer, I have four other Windows 7 computers being backed up to a share on a Western Digital Sentinel DX4000, which is a Windows Server 2008 Storage device. All the Windows 7 computers can be backed up without any issues, including the system images. On my new Windows 8 computer, the back up will fail when the destination is on that share. It will work if I point the destination to locally attached USB hard drive.
To make matter worse, once I configured Windows 7 backup on my Windows 8 computer, I would have to disable Windows 7 backup before I could use the File History feature. I don't understand why we cannot have two types of backups for redundancy.