Win 7 SP1 fails with E_FAIL 0x80004005

Anonymous
2011-02-23T19:11:43+00:00

Hi, I can't get Windows 7 Service Pack 1 to install. I'm running Ultimate. I''m installing via Windows Update. I've got internet access. I've tried multiple times, but I always get an E_FAIL 0x80004005. I looked in the CBS.log and find (around the error) this:

2011-02-23 17:49:23, Info                  CBS    TrustedInstaller service starts successfully.

2011-02-23 17:49:23, Info                  CBS    SQM: Initializing online with Windows opt-in: False

2011-02-23 17:49:23, Info                  CBS    SQM: Cleaning up report files older than 10 days.

2011-02-23 17:49:23, Info                  CBS    SQM: Requesting upload of all unsent reports.

2011-02-23 17:49:23, Info                  CBS    SQM: Failed to start upload with file pattern: C:\Windows\servicing\sqm\*_std.sqm, flags: 0x2 [HRESULT = 0x80004005 - E_FAIL]

2011-02-23 17:49:23, Info                  CBS    SQM: Failed to start standard sample upload. [HRESULT = 0x80004005 - E_FAIL]

2011-02-23 17:49:23, Info                  CBS    SQM: Queued 0 file(s) for upload with pattern: C:\Windows\servicing\sqm\*_all.sqm, flags: 0x6

2011-02-23 17:49:23, Info                  CBS    SQM: Warning: Failed to upload all unsent reports. [HRESULT = 0x80004005 - E_FAIL]

2011-02-23 17:49:23, Info                  CBS    No startup processing required, TrustedInstaller service was not set as autostart, or else a reboot is still pending.

2011-02-23 17:49:23, Info                  CBS    NonStart: Checking to ensure startup processing was not required.

2011-02-23 17:49:23, Info                  CSI    00000004 IAdvancedInstallerAwareStore_ResolvePendingTransactions (call 1) (flags = 00000004, progress = NULL, phase = 0, pdwDisposition = @0x55fb5c

2011-02-23 17:49:23, Info                  CSI    00000005 Creating NT transaction (seq 1), objectname [6]"(null)"

2011-02-23 17:49:23, Info                  CSI    00000006 Created NT transaction (seq 1) result 0x00000000, handle @0x1c4

2011-02-23 17:49:23, Info                  CSI    00000007@2011/2/23:16:49:23.537 CSI perf trace:

CSIPERF:TXCOMMIT;11544

Any ideas on how to fix it would be appreciated.

Regards,

Mike

Windows for home | Previous Windows versions | Windows update

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments
Answer accepted by question author
Anonymous
2011-04-11T05:31:43+00:00

Right on.  I also did an in place upgrade (or what some others call a repair installation), and SP1 installed after the 1-2 hours it took to redo the installation.  Pain in the butt, but it worked.  I'm surprised no one from the Microsoft support team has posted this as a possible solution on these forums--I've only seen it mentioned by community members like NickMoul.

Was this answer helpful?

0 comments No comments
Answer accepted by question author
Anonymous
2011-04-05T08:45:02+00:00

After trying everything, I performed an in place upgrade, using a DVD I had of my version of Windows 7. Don't forget to write down your activation code before you do it.

After inplace upgrade SP1 installed with no issues. I have no idea what was wrong, but W7 performs same as before.

MS needs to sort this out with a Fix-It link.

Only clue was that the inplace upgrade notified me that dot NET 4 was e corrupted and needed a reinstall which it downloaded and reinstalled. Hope that help someone.

Best of luck.

Support? What support?

Was this answer helpful?

0 comments No comments

54 additional answers

Sort by: Oldest
  1. Anonymous
    2011-04-12T14:53:13+00:00

    Wow, the last two posts look promising. I had definitely given up and then felt adventurous after a few months now. My frustration is the same but with a slightly different outcome. SP1 downloaded, installed, then my troubles began. The desktop rebooted and exclaimed a failure with no number and proceeded to return my OS back to pre SP1. All my normal critical and elected updates are up to date but SP1 remains uninstalled. I will try the above in-place upgrade and see what happens. Upon success, I will re-post. O yeah this frustration was happened with 32 bit HP. The only machine out of 8 given me such a migraine.  

    Follow-up 5/11/2011, After reading a blog post by Ed Bott, Ed suggested that patch Tuesday (5/10) addressed this issue. OK, so I proceed an attempt at installing SP1 once again, only to learn that it leaves the machine in a constant re-boot exactly as before. Setting an earlier restore point fixes the OS but obviously to a condition w/o SP1. Come on MS, keep the fixes coming........sooner or later it will happen.

    Was this answer helpful?

    0 comments No comments
  2. Anonymous
    2011-04-12T15:34:40+00:00

    the 80004005 translates to "unspecified error" so it's not of much help.

    I can't believe no one has mentioned this. Yes 80004005 means "unspecified error" because it could be one of many things, but that doesn't mean it's not a bit specific.

    "With error 80004005 there is usually an element of access denied.  Insufficient rights, wrong permissions."

    So for this:

    2011-02-23 17:49:23, Info                  CBS    SQM: Failed to start standard sample upload. [HRESULT = 0x80004005 - E_FAIL]

    2011-02-23 17:49:23, Info                  CBS    SQM: Warning: Failed to upload all unsent reports. [HRESULT = 0x80004005 - E_FAIL]

    Let's say, windows/an anti-virus/anything monitoring your computer sees SP1 uploading something such as a report (above), but it doesn't realise SP1 is to be trusted. What do you think would happen?

    I think it would deny SP1 access from uploading, and as said above, 80004005 can mean access denied.

    Was this answer helpful?

    0 comments No comments
  3. Anonymous
    2011-05-02T17:41:50+00:00

    Mike,

    It might be possible that the Trusted installer exe service is accidentally or for any other reason off on your computer. You may try to check its status and turn it on manually. I believe this would be enough to resolve the issue specified.

    Was this answer helpful?

    0 comments No comments