My Window is 32 bit. So, I only need to copy 1 esent.dll file from the old HDD to replace to new HDD?
The version # of the esent.dll is 6.1.7600.16952 But I still can't install the Hotfix again in the new HDD. Error Code = 0xc8000247
This browser is no longer supported.
Upgrade to Microsoft Edge to take advantage of the latest features, security updates, and technical support.
I used EASEUS Diskcopy to clone a harddisk (new disk 750 GB) and now windows update does not work. Any suggestions?
Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.
My Window is 32 bit. So, I only need to copy 1 esent.dll file from the old HDD to replace to new HDD?
The version # of the esent.dll is 6.1.7600.16952 But I still can't install the Hotfix again in the new HDD. Error Code = 0xc8000247
The Esent.dll located in Windows\SysWOW64 is for 64 bit (x64) systems. I'm not sure if your computer is x64 or 32 bit (x86), HoYIU.
Since you managed to get KB982018 installed, then esent.dll should be now at the Version shown in the KB article, most likely, V. 6.1.7600.16592. That should fix the Windows Update and Windows Defender services issue.
Hi MowGreen, I uninstalled the SP1 in my old HDD, and successfully installed the Hotfix 982018. I only need to copy C:\Windows\System32\esent.dll? As I did not found Windows\SysWOW64\esent.dll
Here it is:
| 2/4/2011 | 01:40:43:606 | 988 | 1060 | AU | # Power management is turned off through policy |
|---|---|---|---|---|---|
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | DtaStor | FATAL: Failed to initialize datastore, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | FATAL: Failed to get session from datastore, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | FATAL: Failed to Unserialize from data store, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | # WARNING: Exit code = 0xC8000247 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | ########### AU: Uninitializing Automatic Updates <br>########### |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | WARNING: InitAUComponents Failed, will restart AU in 30 mins, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | AU Restart required.... |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | ########### AU: Initializing Automatic Updates <br>########### |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | AU setting next detection timeout to 2011-04-01 17:40:43 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | AU setting next sqm report timeout to 2011-04-01 17:40:43 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | DtaStor | FATAL: Failed to initialize datastore, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | Agent | WARNING: GetServiceList failed with error 0xc8000247. |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | WARNING: QueryRegisteredProvider failed with error 0xc8000247 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | # Approval type: Scheduled (User preference) |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | # Scheduled install day/time: Every day at 3:00 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | # Auto-install minor updates: Yes (User preference) |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | # Will interact with non-admins (Non-admins are elevated (User preference)) |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | # Power management is turned off through policy |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | DtaStor | FATAL: Failed to initialize datastore, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | FATAL: Failed to get session from datastore, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | FATAL: Failed to Unserialize from data store, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | # WARNING: Exit code = 0xC8000247 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | ########### AU: Uninitializing Automatic Updates <br>########### |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | WARNING: InitAUComponents Failed, will restart AU in 30 mins, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | AU Restart required.... |
| 2/4/2011 | 01:40:43:616 | 4092 | 1784 | WUApp | WARNING: Error displaying Opted In Service summary: 8024A000 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | ########### AU: Initializing Automatic Updates <br>########### |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | AU setting next detection timeout to 2011-04-01 17:40:43 |
| 2/4/2011 | 01:40:43:616 | 988 | 1060 | AU | AU setting next sqm report timeout to 2011-04-01 17:40:43 |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | DtaStor | FATAL: Failed to initialize datastore, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | Agent | WARNING: GetServiceList failed with error 0xc8000247. |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | WARNING: QueryRegisteredProvider failed with error 0xc8000247 |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | # Approval type: Scheduled (User preference) |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | # Scheduled install day/time: Every day at 3:00 |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | # Auto-install minor updates: Yes (User preference) |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | # Will interact with non-admins (Non-admins are elevated (User preference)) |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | # Power management is turned off through policy |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | DtaStor | FATAL: Failed to initialize datastore, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | FATAL: Failed to get session from datastore, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | FATAL: Failed to Unserialize from data store, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | # WARNING: Exit code = 0xC8000247 |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | ########### AU: Uninitializing Automatic Updates <br>########### |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | WARNING: InitAUComponents Failed, will restart AU in 30 mins, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | AU Restart required.... |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | ########### AU: Initializing Automatic Updates <br>########### |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | AU setting next detection timeout to 2011-04-01 17:40:43 |
| 2/4/2011 | 01:40:43:626 | 988 | 1060 | AU | AU setting next sqm report timeout to 2011-04-01 17:40:43 |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | DtaStor | FATAL: Failed to initialize datastore, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | Agent | WARNING: GetServiceList failed with error 0xc8000247. |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | AU | WARNING: QueryRegisteredProvider failed with error 0xc8000247 |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | AU | # Approval type: Scheduled (User preference) |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | AU | # Scheduled install day/time: Every day at 3:00 |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | AU | # Auto-install minor updates: Yes (User preference) |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | AU | # Will interact with non-admins (Non-admins are elevated (User preference)) |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | AU | # Power management is turned off through policy |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | DtaStor | FATAL: Failed to initialize datastore, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | AU | FATAL: Failed to get session from datastore, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | AU | FATAL: Failed to Unserialize from data store, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | AU | # WARNING: Exit code = 0xC8000247 |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | AU | ########### AU: Uninitializing Automatic Updates <br>########### |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | AU | WARNING: InitAUComponents Failed, will restart AU in 30 mins, error = 0xC8000247 |
| 2/4/2011 | 01:40:43:636 | 988 | 1060 | AU | AU Restart required.... |
| 2/4/2011 | 01:40:46:678 | 4092 | 1784 | WUApp | WARNING: Couldn't handle 'Check for Updates' click -- service not running |
Ignore my previous post if you happened to see it, HoYIU. The Hotfix will not resolve this issue as SP1 has already been applied. The Version of the Hotfix only applies to esent.dll on Win 7 RTM ( the original release of Win 7 ).
The only suggestion left is to uninstall SP1 on the computer ( if that can be done ) extract esent.dll from KB982018, replace esent.dll, check to see if Windows Update functions, apply SP1, and then clone the HD.
If you had a reliable, fully functioning backup, we could try the HP update that resolved this issue on another Sony laptop earlier in this thread that was posted by Tom6455 on January 28 -
Error Messages Appear During Windows Update, When Inserting Card or Using Live Mail
It's an update for the Intel Rapid Storage Technology Driver (IRRT) but specifically mentions Western Digital 'high density' HDs.