MS SQL Server 2008 Service Pack 2 (KB2285068) Error Code 84C40007

Anonymous
2010-11-23T19:55:18+00:00

I've been trying to install this update via Windows Update, however, every time it begins the installation, it gives me this Error Code 84C40007. When I check the update history, it shows this update has "Failed" to install.

I haven't done anything beyond this, however, I have downloaded the same update from the MS site and am thinking of just installing it manually. However, I'd like to find out why it keeps failing to install through Windows Update and what this error code means?

I've never had problems installing Windows updates before so am not sure why this suddenly came up. I would appreciate any help.

Just to add, I did install one other update (KB2447568) at the same time through Windows Update and everything went smoothly. That update installed with no problems at all.

My specs:

Operating System: Win 7 Professional

System Type: 32 bits

Anti-virus: Microsoft Security Essentials (the most current virus and spyware definitions)

Windows for home | Previous Windows versions | Windows update

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments
Answer accepted by question author
Anonymous
2010-11-23T22:35:17+00:00

You need Microsoft .NET Framework 4: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=9cfb2d51-5ff4-4491-b0e5-b386f32c0992&displaylang=en

I had gotten the same error so I downloaded the full install from http://www.microsoft.com/downloads/en/details.aspx?FamilyID=8fbfc1de-d25e-4790-88b5-7dda1f1d4e17.  When I tried to install the Service Pack I recieved an error asking for .NET Framework 4.  I installed the framework and re-ran windows update, everything installed fine.  Didn't even use the full service pack install.

Was this answer helpful?

2 people found this answer helpful.
0 comments No comments

55 additional answers

Sort by: Newest
  1. Anonymous
    2010-12-02T20:22:11+00:00

    Below is my SQLsetup.log I am using Windows 7 Professional 32 bit. I had the 4.0 Client profile installed as well as the default 3.5 sp1 that came with windows.

    11/26/2010 11:04:06.740 ======================================================================

    11/26/2010 11:04:06.838 Setup launched

    11/26/2010 11:04:06.863 Attempting to determine media source

    11/26/2010 11:04:06.888 Media source value not specified on command line argument.

    11/26/2010 11:04:06.913 Setup is launched from media directly so default the value to the current folder.

    11/26/2010 11:04:06.938 Media source: c:\d84440adac34fdaa68\

    11/26/2010 11:04:06.963 Attempt to determine media layout based on file 'c:\d84440adac34fdaa68\mediainfo.xml'.

    11/26/2010 11:04:07.290 Media layout is detected as: Core

    11/26/2010 11:04:07.353 Media LCID is detected as: 1033

    11/26/2010 11:04:07.378 Not a slip stream media, so continuing to run setup.exe from media.

    11/26/2010 11:04:07.403 /? or /HELP or /ACTION=HELP specified: false

    11/26/2010 11:04:07.437 Help display: false

    11/26/2010 11:04:07.461 Checking to see if we need to install .Net version 4.0

    11/26/2010 11:04:07.485 Determining the cluster status of the local machine.

    11/26/2010 11:04:07.512 The local machine is not configured as a cluster node.

    11/26/2010 11:04:07.535 Attempting to find media for .Net version 4.0

    11/26/2010 11:04:07.560 .Net version 4.0 needs to be installed from media: c:\d84440adac34fdaa68\

    11/26/2010 11:04:07.627 Error: Unable to find media for .Net version 4.0

    11/26/2010 11:04:07.744 Setup closed with exit code: 0x84C40007

    11/26/2010 11:04:07.835 ======================================================================

    Was this answer helpful?

    0 comments No comments
  2. Anonymous
    2010-12-02T03:13:26+00:00

    Hi all,

    We are still investigating the root cause of this issue. if you encounter this issue, please post the contents of your sqlsetup.log file that is located at %temp% or C:\Users\Administrator\AppData\Local\Temp to the forum**.**

    Thanks,

    Peter Saddow [Microsoft -- SQL Server Development Team]


    This posting is provided "AS IS" with no warranties, and confers no rights.


    This posting is provided "AS IS" with no warranties, and confers no rights.

    Was this answer helpful?

    0 comments No comments
  3. Anonymous
    2010-12-02T01:44:11+00:00

    Hi from Paris France :)

    Thank you Shane I applied your solution and it worked fine !

    Thanks a lot, you saved me hours of searching what was wrong with Windows Update error....

    Balagan

    Was this answer helpful?

    0 comments No comments
  4. Anonymous
    2010-12-01T19:14:39+00:00

    Worked for me as well. windows 7 x64; thanks.

    Was this answer helpful?

    0 comments No comments