Backup aborts with error code 0x80070422

Anonymous
2010-04-11T21:54:55+00:00

Can not run 'change settings' in backup.  I get a message: "The service could not be started either because it is disabled or it has no enabled device associated with it. 0x80070422".  I'm running Windows 7 Professional on a 64 bit laptop.  Anybody have the same problem or a solution?  Thanks.

Windows for home | Previous Windows versions | Windows update

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments
Answer accepted by question author
Anonymous
2010-04-12T15:39:52+00:00

Hi,

This error usually occurs if one of the services required for windows backup to work is disabled or not started.

To check for the services, click on start, in the start search bar type services and then press enter.

Please check that the following services are enabled:

  • "Remote Procedure Call" (RPCSS) should be enabled, Automatic.
  • "COM+ Event System" (EventSystem) should be enabled, Manual.
  • "System Event Notification Service" (SENS) should be enabled, Automatic.
  • "Volume Shadow Copy" (VSS) should be enabled, Manual.
  • "Microsoft Software Shadow Copy Provider" (SWPRV) should be enabled, manual.

Once you make any changes according to the specifications listed above, you can try a backup and check if that resolves the issue.

I would also suggest you to run a SFC scan.

How to use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7

http://support.microsoft.com/default.aspx/kb/929833?p=1

Hope this information is helpful. Please let us know if you require further help.

Regards

Rehman – Microsoft Support

Was this answer helpful?

10+ people found this answer helpful.
0 comments No comments
Answer accepted by question author
Anonymous
2014-10-09T04:10:08+00:00

This was it for me too. Brings up some questions... The big one is... Why was this disabled in the first place???  Would a backup service like Carbonite do this? and how would it have permission? That is a little paranoid. So I still wonder why. Is it part of a windows update? But... this worked. Sure would like to know why my install didn't automatically enable a service that is supposed to just work.

Thanks, Tom

Was this answer helpful?

10+ people found this answer helpful.
0 comments No comments

43 additional answers

Sort by: Newest
  1. Anonymous
    2013-08-10T10:07:17+00:00

    Can not run 'change settings' in backup.  I get a message: "The service could not be started either because it is disabled or it has no enabled device associated with it. 0x80070422".  I'm running Windows 7 Professional on a 64 bit laptop.  Anybody have the same problem or a solution?  Thanks.

    WINDOWS 7 x64 BACKUP ERROR MESSAGE

    "The service could not be started either because it is disabled or it has no enabled device associated with it. 0x80070422".

    Nothing posted to Feb 2013 worked. Simply do as below :-

    To check for the services, click on start, in the start search bar type services and then press enter.

    Please check that the following services are enabled:

    Windows Backup set from Disabled to Automatic

    Presto, so simple

    Hi,

    Thanks, it Works.

    Best regards,

    Jose Luis Gomez

    Was this answer helpful?

    0 comments No comments
  2. Anonymous
    2013-06-03T23:38:37+00:00

    And, of course, the one service that was disabled on my machine was "Windows Backup." Make sure that's enabled too!

    Was this answer helpful?

    1 person found this answer helpful.
    0 comments No comments
  3. Anonymous
    2013-02-08T05:48:16+00:00

    Can not run 'change settings' in backup.  I get a message: "The service could not be started either because it is disabled or it has no enabled device associated with it. 0x80070422".  I'm running Windows 7 Professional on a 64 bit laptop.  Anybody have the same problem or a solution?  Thanks.

    WINDOWS 7 x64 BACKUP ERROR MESSAGE

    "The service could not be started either because it is disabled or it has no enabled device associated with it. 0x80070422".

    Nothing posted to Feb 2013 worked. Simply do as below :-

    To check for the services, click on start, in the start search bar type services and then press enter.

    Please check that the following services are enabled:

    Windows Backup set from Disabled to Automatic

    Presto, so simple

    Was this answer helpful?

    20+ people found this answer helpful.
    0 comments No comments