Cannot start windows event log service on Windows 7. Error 4201.__

Anonymous
2009-11-15T05:12:47+00:00

Cannot start the Windows Event Log service on Local Computer.  Error 4201: The instance name passed was not recognized as valid by a WMI data provider.

Windows for home | Previous Windows versions | Windows update

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments
Answer accepted by question author
Anonymous
2009-11-15T15:54:26+00:00

Hi Ramesh,

That did the trick.  For the record:

  1. Used msconfig to switch to safe mode boot
  2. Booted to safe mode
  3. ran cmd.exe as an administrator
  4. typed "cd C:\Windows\System32\LogFiles\WMI"
  5. typed "rename RtBackup RtBackup2"
  6. Used msconfig to switch to normal boot mode
  7. Reboot and found event viewer working

Thank you! 

Rung

Was this answer helpful?

40+ people found this answer helpful.
0 comments No comments
Answer accepted by question author
Ramesh 181.7K Reputation points Volunteer Moderator
2009-11-15T06:53:44+00:00

Hi rung_windows7,

Renaming or deleting the following folder seems to work for some users:

C:\Windows\System32\LogFiles\WMI\RtBackup

REF: Event log error 4201 - ERROR_WMI_INSTANCE_NOT_FOUND (a helluva great thread)


Ramesh Srinivasan, Microsoft MVP [Windows Desktop Experience]

Was this answer helpful?

3 people found this answer helpful.
0 comments No comments

60 additional answers

Sort by: Newest
  1. Anonymous
    2010-06-18T01:01:09+00:00

    How many files are in the folder?  (I've got 10 files in that folder and in another sub-folder.)  Can you perform the command on each file individually, from an elevated command prompt?  (Replace *.* with a file name, and drop the /s switch; change to any sub-folder independently and perform the same action there.)

    Was this answer helpful?

    0 comments No comments
  2. Anonymous
    2010-06-18T00:17:05+00:00

    I've got the same problem and I've followed all above directions right down the very last letter.

    "So, I followed the instuctions to get to the C:\Windows\System32\LogFiles\WMI\  folder, then I typed (I think!):

    attrib -r -s *.* /s

    Spaces are important!"

    When I enter the attrib -r -s *.* /s command, I still get "access denied" ...

    I'm in the windows admin account, safe mode, and I'm also running cmd as an administrator.

    Any ideas???

    Was this answer helpful?

    0 comments No comments
  3. Anonymous
    2010-06-03T22:29:47+00:00

    Hi,

    I had the same problem in Safe Mode.

    The answer is to remove attributes from the folder, while in CMD at the C:\Windows\System32\LogFiles\WMI\  folder.

    So, I followed the instuctions to get to the C:\Windows\System32\LogFiles\WMI\  folder, then I typed (I think!):

    attrib -r -s *.* /s

    Spaces are important!

    My wireless modem now works on Win 7 -  !!!!!

    Cheers

    Was this answer helpful?

    0 comments No comments