Cannot start windows event log service on Windows 7. Error 4201.__

Anonymous
2009-11-15T05:12:47+00:00

Cannot start the Windows Event Log service on Local Computer.  Error 4201: The instance name passed was not recognized as valid by a WMI data provider.

Windows for home | Previous Windows versions | Windows update

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments
Answer accepted by question author
Anonymous
2009-11-15T15:54:26+00:00

Hi Ramesh,

That did the trick.  For the record:

  1. Used msconfig to switch to safe mode boot
  2. Booted to safe mode
  3. ran cmd.exe as an administrator
  4. typed "cd C:\Windows\System32\LogFiles\WMI"
  5. typed "rename RtBackup RtBackup2"
  6. Used msconfig to switch to normal boot mode
  7. Reboot and found event viewer working

Thank you! 

Rung

Was this answer helpful?

40+ people found this answer helpful.
0 comments No comments
Answer accepted by question author
Ramesh 181.7K Reputation points Volunteer Moderator
2009-11-15T06:53:44+00:00

Hi rung_windows7,

Renaming or deleting the following folder seems to work for some users:

C:\Windows\System32\LogFiles\WMI\RtBackup

REF: Event log error 4201 - ERROR_WMI_INSTANCE_NOT_FOUND (a helluva great thread)


Ramesh Srinivasan, Microsoft MVP [Windows Desktop Experience]

Was this answer helpful?

3 people found this answer helpful.
0 comments No comments

60 additional answers

Sort by: Newest
  1. Anonymous
    2010-12-06T09:17:51+00:00

    It works for me

    I was able to rename C:\Windows\System32\LogFiles\WMI\RtBackup

    from my normal login without safemode.

    Thanks

    Was this answer helpful?

    0 comments No comments
  2. Anonymous
    2010-09-17T00:45:27+00:00

    I've had the same issue with the event viewer/log. However I have been using registry cleaning programs so I used restore registry feature to restore backup i'd made and after reboot the issue was fixed.

    Was this answer helpful?

    0 comments No comments
  3. Anonymous
    2010-09-14T15:08:01+00:00

    Here's what I did. I restarted Windows in Safe mode and changed the ownership of the whole C drive to the local machine administrators group. Once that finished, I rebooted and everything worked correctly. I do recall changing ownership to my domain account a week or so ago so maybe that did it?

    Was this answer helpful?

    0 comments No comments