SERVER 2022: Random failures with: Windows Backup failed to get an exclusive lock on the EFI system partition (ESP)

Anonymous
2024-01-24T11:40:42+00:00

Various new fresh installations on HP and Dell ( mainly entry level servers) Windows server 2022 essentials set simple workgroup no domain or PDC etc...s various backup disks , tried secureboot on off tried AV removed / off (Defender) checked user its running as , removed and reinstalled backup etc etc

Nothing helps keep getting occasional Windows Backup failed to get an exclusive lock on the EFI system partition (ESP) and backup fails as it wont run

Thanks anyone who can help !

Windows for business | Windows Server | Storage high availability | Other

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments
Answer accepted by question author
Anonymous
2024-05-29T11:58:49+00:00

No, we run VMWare on Lenovo servers. EDIT: I've now also seen this problem on a Fujitsu server (no WMWare); random, about 1-2 times/month.

We haven't solved the issue through Microsoft support yet, but a workaround from MS has been applied, and there's been no WSB fails the last week.

(Note that in addition to this workaround, I wrote a script that checks the status of the VSS writers and writes it to a file, and is scheduled to run just before the WSB task, and 10 and 20 minutes into the task. Not that I can see why this would have any impact on the WSB task...)

Applied workaround:

  1. Open “Run” and enter “taskchd.msc” to launch Task Scheduler.
  2. Navigate to Microsoft/Windows/Backup
  3. Select Microsoft-Windows-WindowsBackup, right click, select properties and navigate to the Settings tab.
  4. Check the box “Allow task to be run on demand”
  5. You can try to select the box “If this task fails”. If this makes your backup work then you can stop here, if this doesn’t work follow the next steps.

 6. Click “OK“ to apply all the changes.

  1. Open cmd and type this command:

schtasks /create /F /RU SYSTEM /RL HIGHEST /SC onevent /EC Application /MO "*[System[Provider[@Name='Microsoft-Windows-Backup'] and (EventID=517)]]" /TN "Microsoft\Windows\Backup\Retry_Backup" /TR "schtasks /run /tn "Microsoft\Windows\Backup\Microsoft-Windows-WindowsBackup""

  1. Refresh the Backup folder in task scheduler.

 Note: on the command the “EventID = 517” section makes the scheduled task search for the backup failing with that event id. If for some reason the id changes then you’ll need to search for the new eventid in the event log and change it to the new eventid.

Was this answer helpful?

2 people found this answer helpful.
0 comments No comments

46 additional answers

Sort by: Oldest
  1. Deleted

    This answer has been deleted due to a violation of our Code of Conduct. The answer was manually reported or identified through automated detection before action was taken. Please refer to our Code of Conduct for more information.


    Comments have been turned off. Learn more

  2. Anonymous
    2024-06-06T08:11:47+00:00

    Yes work around appear to do the trick, its not ideal as it could potentially create a loop on the failure. Pitty you closed this with microsoft as its something that really needs fixing properly .

    However in answer to your question creating the scheduled task to trigger a manual retry does seem to work and finally (worst retries was about 7 each a few minutes apart) we get a backup every day since i implemented the extra schedule.

    Br Ian

    Great to hear! Microsoft Support works that way; if they don't deem it critical, and they have found a workaround, they pass on the information to the developers, close the case, and ask that you check out the Windows Server 2022 | Microsoft Learn every now and then.

    That said: the case is re-opened, as soon as I leave another reply. :)

    Was this answer helpful?

    0 comments No comments