SERVER 2022: Random failures with: Windows Backup failed to get an exclusive lock on the EFI system partition (ESP)

Anonymous
2024-01-24T11:40:42+00:00

Various new fresh installations on HP and Dell ( mainly entry level servers) Windows server 2022 essentials set simple workgroup no domain or PDC etc...s various backup disks , tried secureboot on off tried AV removed / off (Defender) checked user its running as , removed and reinstalled backup etc etc

Nothing helps keep getting occasional Windows Backup failed to get an exclusive lock on the EFI system partition (ESP) and backup fails as it wont run

Thanks anyone who can help !

Windows for business | Windows Server | Storage high availability | Other

Locked Question. This question was migrated from the Microsoft Support Community. You can vote on whether it's helpful, but you can't add comments or replies or follow the question.

0 comments No comments
Answer accepted by question author
Anonymous
2024-05-29T11:58:49+00:00

No, we run VMWare on Lenovo servers. EDIT: I've now also seen this problem on a Fujitsu server (no WMWare); random, about 1-2 times/month.

We haven't solved the issue through Microsoft support yet, but a workaround from MS has been applied, and there's been no WSB fails the last week.

(Note that in addition to this workaround, I wrote a script that checks the status of the VSS writers and writes it to a file, and is scheduled to run just before the WSB task, and 10 and 20 minutes into the task. Not that I can see why this would have any impact on the WSB task...)

Applied workaround:

  1. Open “Run” and enter “taskchd.msc” to launch Task Scheduler.
  2. Navigate to Microsoft/Windows/Backup
  3. Select Microsoft-Windows-WindowsBackup, right click, select properties and navigate to the Settings tab.
  4. Check the box “Allow task to be run on demand”
  5. You can try to select the box “If this task fails”. If this makes your backup work then you can stop here, if this doesn’t work follow the next steps.

 6. Click “OK“ to apply all the changes.

  1. Open cmd and type this command:

schtasks /create /F /RU SYSTEM /RL HIGHEST /SC onevent /EC Application /MO "*[System[Provider[@Name='Microsoft-Windows-Backup'] and (EventID=517)]]" /TN "Microsoft\Windows\Backup\Retry_Backup" /TR "schtasks /run /tn "Microsoft\Windows\Backup\Microsoft-Windows-WindowsBackup""

  1. Refresh the Backup folder in task scheduler.

 Note: on the command the “EventID = 517” section makes the scheduled task search for the backup failing with that event id. If for some reason the id changes then you’ll need to search for the new eventid in the event log and change it to the new eventid.

Was this answer helpful?

2 people found this answer helpful.
0 comments No comments

46 additional answers

Sort by: Newest
  1. Anonymous
    2024-06-03T11:51:06+00:00

    Dear community,

    Good day.

    That sounds as a working workaround.. I think Microsoft has to do some digging still, but maybe, Ian, you can mark this solution for now?

    Yours sincerely,

    Bjarne Petersen

    Was this answer helpful?

    0 comments No comments
  2. Anonymous
    2024-06-03T11:23:30+00:00

    I added step 7 in and so far it's been working. It will fail initially but then the backup runs again a few seconds later and completes.

    Was this answer helpful?

    0 comments No comments
  3. Anonymous
    2024-06-03T09:58:51+00:00

    You are absolutely right; a bit hectic these days... Will correct my posts, thanks.

    Was this answer helpful?

    0 comments No comments
  4. Anonymous
    2024-06-03T09:33:06+00:00

    Hi, @jeffKeystone.

    Did step 6 fail, or did the backup still fail after doing step 6?

    I see now that I failed to have a closer look at step 7. Here you have to change EventID to what you can see in the Event Viewer at the time the backup fails (Filter Current Log -> Event level: Error and Event sources: Backup). For me this has been both 517 and 518, so I changed it accordingly and created two separate tasks; like this:

    Event ID: 517

    schtasks /create /F /RU SYSTEM /RL HIGHEST /SC onevent /EC Application /MO "*[System[Provider[@Name='Microsoft-Windows-Backup'] and (EventID=517)]]" /TN "Microsoft\Windows\Backup\Retry_Backup_Error517" /TR "schtasks /run /tn \"Microsoft\Windows\Backup\Microsoft-Windows-WindowsBackup\""
    

    Event ID: 518

    schtasks /create /F /RU SYSTEM /RL HIGHEST /SC onevent /EC Application /MO "*[System[Provider[@Name='Microsoft-Windows-Backup'] and (EventID=518)]]" /TN "Microsoft\Windows\Backup\Retry_Backup_Error518" /TR "schtasks /run /tn \"Microsoft\Windows\Backup\Microsoft-Windows-WindowsBackup\""
    

    I am not sure about the event 581 : This event is logged when backup started failed as another backup or recovery is in progress. A backup operation can fail if another backup or recovery operation is running at the same time.

    So I would say its only the 517 thats needed ..

    Also if you believe you need the 518 ( Which I doubt) you can add multiple triggers in the Triggers section rather than having multiple tasks: "Each task can contain one or more triggers, which means there are many ways that you can start a task. If a task has multiple triggers, Task Scheduler starts the task when any of the triggers occur"

    If you have desktop experience then you can do this easily via the gui, the command line is a bit more tricky but dooable

    Was this answer helpful?

    0 comments No comments