This is indeed a legitimate issue. We had the same issue, still with varying drops among members (no servers dropped). It seems that older machines are not affected, they may have a RC4+AES128/256 SHA1 encryption type only (with no futures), just guessing, no tests have been done.
Still i tested Linux Kerberos clients extensively, they are affected too:
https://gitlab.freedesktop.org/realmd/adcli/-/issues/40
We had to change password computer account via ldap password reset (it directly writing ldap object properties).
What happens:
- Trust-dropping machines: Password is actually changed via Kerberos flow (DC writes the new value in AD DS), but it reports an error message. Machine receives the error, so it discards the new krb5.keytab and maintains the older one. This results in a mismatch between lcoal machine password, and AD DS hashes. Machine passwords do not expire, so it is the password resets that breaks trust between machine and ADDS, we put a password reset cycle of 120d so we can wait a CU.
- Non trust dropping machines, but they have not updated password in a while. Same as before, but they fail before, and password is not actually changed in DS.
- User passwords change via Ctrl+Alt+Supr options is also affected.